[Solved] Nextcloud too new?

I’m getting an error message about Nextcloud not supporting downgrades:

Primary Hostname: ****
Public IP Address: ****
Public IPv6 Address: ****
Private IP Address:
Mail-in-a-Box Version:  v0.42b

Updating system packages...
Installing system packages...
Initializing system random number generator...
Firewall is active and enabled on system startup
Installing nsd (DNS server)...
Installing Postfix (SMTP server)...
Installing Dovecot (IMAP server)...
Installing OpenDKIM/OpenDMARC...
Installing SpamAssassin...
Installing Nginx (web server)...
Installing Roundcube (webmail)...
Installing Nextcloud (contacts/calendar)...
Upgrading Nextcloud --- backing up existing installation, configuration, and database to directory to /home/user-data/owncloud-backup/2019-08-28-13:31:58...

FAILED: sudo -u www-data php /usr/local/lib/owncloud/console.php app:disable user_external
An unhandled exception has been thrown:
OC\HintException: [0]: Downgrading is not supported and is likely to cause unpredictable issues (from to ()

What exactly are you trying to do??? Please be specific and please advise what version of MiaB you have.

It looks like he is updating from an older version of MIAB (which may or may not have been modified to have the latest Nextcloud)

That is my assumption as well hence the question … :slight_smile:

Updating from v0.30 to v0.42b is absolutely broken - a fix is on the way … but updating from v0.41 to v0.42b is a different story.

LTNS, hope all is well. :slight_smile:

I feel like this might be a result of the dreaded v0.42 update. If you were one of the unlucky people to get 0.42 (like me…), you’ll get this error going to 0.42b.

v0.42 (July 4, 2019)


* Decreased the minimum supported RAM to 502 Mb.
* Improved mail client autoconfiguration.
* Added support for S3-compatible backup services besides Amazon S3.
* Fixed the control panel login page to let LastPass save passwords.
* Fixed an error in the user privileges API.
* Silenced some spurrious messages.

Software updates:

* Upgraded Roundcube from 1.3.8 to 1.3.9.
* Upgraded Nextcloud from 14.0.6 to 15.0.8 (with Contacts from 2.1.8 to 3.1.1 and
Calendar from 1.6.4 to 1.6.5).
* Upgraded Z-Push from 2.4.4 to 2.5.0.

I think that in the end everything worked out OK, but I did have to flush and restore the NextCloud data.

1 Like

Hey @blinkingline LTNS … will you elaborate please? thanks!

When I applied the 0.42b update, I got the same error as OP, that I was trying to downgrade from to At the time, I just left it, hoping things would be okay.

After a few days I noticed some contacts weren’t syncing correctly across devices, dug around a little bit and saw this post.

Deleted the user-data for Own/Nextcloud, then re-ran setup and then re-synced devices back and everything was fine.

1 Like

@blinkingline is right. I got the 0.42 upgrade followed by 0.42b.

Thanks for the tip about deleting nextcloud data. I’ll try that and report back.

Thanks all. Can now confirm that deleting the “owncloud” data in /home/user-data, and running the update again (which actually upgraded me to v0.43) has worked and NextCloud is now working.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.