[SOLVED] New MIAB Setup | Glue Records / Nameservers issue

Not sure what I’m doing wrong. My primary domain has been setup and running for years with no issues, and I’ve setup a few businesses using Namecheap, so I’m familiar with their unique way of actually getting nameservers set.

But this new Domain is being stubborn, and not reporting nameservers or dns correctly. Namecheap says the nameservers are correct, but when I run dns checks, the servers come up as No IP.


ns1.mail.ongaku.gg (
ns2.mail.ongaku.gg (

  • VPS is digital ocean
  • IP is
  • vps hostname is set to “mail.ongaku.gg”
  • nameservers are added and set on namecheap
  • I’ve waited 48 hours, twice (did a full vps / nameserver refresh)
  • dns checks reports nameservers as empty IPs

The .gg domain requires two separate name servers AND it does NOT support ns on a subdomain.

You need to find a different domain to use to run your MiaB. @david.blythe

Is that an IANA requirement? That is midly frustrating, but I can potentially manage. My 7 year old .com MiaB Instance can act as the DNS for this I guess. Can those nameservers be specified if they are subdomain, or is it just .gg subdomains that aren’t allowed?

It is .gg registry rules.

.com’s are not a problem … as the naming convention MiaB uses is box.domain.com with the NS being ns1.box.domain.com and ns2.box.domain.com. Same for most TLD’s. But there are a few (mentioned in the installation guide) that simply are problematic for one reason or another.

If you are suggesting what I think you are suggesting, sure you can use the same domain for more than one install of MiaB. Each install will have it’s own unique hostname / subdomain. So yes, you can have box.domain.com as well as mail.domain.com, etc. DNS can be a slight bit tricky for the uninitiated, but it is absolutely do-able.

Using my .com Nameservers (ns1.mail.example.com) ended up working for the .gg domain, in case anyone else runs into this edge case.

Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.