(SOLVED) Need help with setting up correct records

As I am not a very technical person, I would like to ask for your help in resolving one problem I am facing with one of my domains - example.com. I have a WordPress site on a server with an IP of which points to the example.com domain which works without any problem and should continue to stay the same, but I am trying to set up a working Mail in a Box server installed on a server with an IP address of The thing is that in the case of me wanting to set up a correctly working mail server, I have to change the A record to point to instead of which means that my website stops working but the mail server works, and vice versa. Is there any workaround this issue? Please let me know.

yes, you will need to use the Mail-in-a-Box Custom DNS settings. Point your domain as described in the setup guide to your Mail-in-a-Box server and use your administration panel settings (System>Custom DNS) to set up an A record to your wordpress website.

Hi pxl,

Thanks for your input. I have done as you have said. I changed System -> Custom DNS -> Set custom DNS records -> example.com, type A, IP and on registrar I changed both nameservers to ns1.box.example.com and ns2.box.example.com. Also set Glue records ns1.box.example.com and ns2.box.example.com to point to and now everything works. I hope this post helps someone like me in the future.

1 Like

Hi pxl,

Just one quick question though. the mail server admin page works when I type the IP address but not when I type box.example.com. Can you please let me know how to solve this one?

Hi Hawk,

does your status page show any red lines? I do not have an idea what could cause the problem. Try to run

sudo mailinabox

again. It might has to fix some things after your set the domain records again.

I ran command mailinabox and saw no problems during the update. The status page shows no red lines, only 2 question marks. One of them being

“Web has been disabled for this domain because you have set a custom DNS record.”

and another

“This domain’s DNSSEC DS record is not set. The DS record is optional. The DS record activates DNSSEC. To set a DS record, you must follow the instructions provided by your domain name registrar and provide to them this information.”

I probably can’t really help you solve it, but here are some more ideas:

  • what happens when you just type in example.com
  • check if you have reverse DNS activated and set right
    if you are on a linux like machine checkout this command:

dig box.example.com
dig box.example.com @

this command request information from name servers, maybe they haven’t updated yet

Hi pixl,

It seems the name servers were not yet updated. Now everything works perfect, so the steps you previously stated is what one needs to do in order to get everything in working order. Many thanks for your help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.