Solved/Guide: Let’s encrypt certificate, Failed authorization procedure renewal

Hi all, sorry for my combined solved/guide first post.

I’ve had some recurring problems on Let’s encrypt(LE) on renewal of certificates on vanilla >0.4 MIAB.
Might be the only one, haven’t seen anyone else - posting this if someone could benefit. No problems on dns, firewall…

LE uses http, MIAB redirect(302) http to https, for me this result repeately in an error on renewal. I might be the only one. There might be other options, configuring ngix, conf options etc to look elsewhere.

My solution has been: Do a symbolic link on MIAB, from “webroot” to “ssl”:

Rename standard HTTP directory:
sudo mv /home/user-data/www/default /home/user-data/www/default1

Do symbolic link from HTTPS to HTTP:
sudo ln -s /home/user-data/ssl/lets_encrypt/webroot/ /home/user-data/www/default

Provision certificates from web or commandline.

Revoke former changes:
sudo rm /home/user-data/www/default1
sudo mv /home/user-data/www/default1 /home/user-data/www/default

Since this is my first post, I’d like to take the opportunity to give my gratitude to the developers of MIAB!
I’ve been using this for years now and much impressed with the quality and change control. If you need any help, please let me know.

All the best, and thank you!
Allan