[Solved] DNSSEC On Master But Not On Slave Allowed?

Hey guys,

ist it allowed to enter the DNSSEC records into my domain when I use ns1.box.domain.com and a second nameserver from another company which doess not support DNSSEC records?!

Sorry if this seems obvious. I wanted to ask, before I make something wrong.


I actually don’t know. It may depend on what not supporting DNSSEC means. But I think it’s likely to work. If you can try it, you can test and see if Google Public DNS (, continues to resolve the domain name correctly – Google Public DNS uses DNSSEC.

Not sure about the not supported. I read it at the guide from @m4rcs about setting up a free secondary DNS for Mail-in-a-Box here. But this part in the guide is a bit confusing:

Unfortunately they don’t support DNSSEC. As this service is run by a company you can buy additional requests etc. So if your email is important you should choose them.

He is referring to buddyns.com and it seems that they doesnt suppoert DNSSEC but he writes that if email is important, I should choose them. Does he mean because they are a company and not maintained by just one person?!

I will give it a try and will update this post. Thanks @JoshData!

Edit: As far as I can tell, it doesnt work. But I found a super perfect solution now, after some hard days figuring all out, like where to host my domains, which servers. How does all this stuff (DNS, email, nginx…) work and so on. Thanks @JoshData for your great help. Actually Mail-in-a-Box and for example Gandi.net are now a big part of my “virtual empire”… Thanks!! :kissing_heart: :grin:

Ah, I mark this as solved. It is, at least for me it is. :thumbsup: