Solved Blacklist Issue


#1

I have both 0.30 and 0.40 installed on two VPS.

I was in RoundCube on each system debugging a problem. I was creating sending mail from one system to the other.

On both systems, mail going to the other was bounced as being blacklisted.

Both systems were working with iOS devices.

Turns out the IP6 address of each system was blocked for some reason. The IP4 addresses were not blocked.

I just followed the instructions in the bounce emails to get the IP6 addresses unblocked.

Hope this helps someone.

Dennis


#2

You must have a unique setup. I have run both .30 and .40 without any IPv6 without this problem.

Also, you should be careful allowing IPv6 as I believe fail2ban does not support IPv6. I think I read something in the setup guide discouraging the use of IPv6 for security purposes.


#3

Thanks I’ll check the setup guide.


#4

I hope you realize that IPv4 is going to be phased out at some point in the future. IoT, the growing population, the demand for more servers and Internet users will completely deplete IPv4 addresses.

Please support Internet freedom by supporting IPv6 as much as you can.


#5

yep. missed that.

So, If i just kill ipv6 at the vps will that mess things up?

Things are working great now.


#6

Not sure what you are talking about. In the original post, you said you solved the problem. There is no need, in my opinion to


#7

The reason I worried about setting up ipv6 was the Status Page indicating it wasn’t setup. FYI


#8

I have not used MiaB with IPv6 so I can’t comment on how removing it will affect your setup. I wouldn’t think it would cause a problem, but I can’t guarantee that. I run my MiaB on DigitalOcean and I do not enable IPv6 without any problems.

The question for you is did your enabling of IPv6 fix your initial problem or was it something else you did or something that resulted from the initialization of IPv6 on your box.


#9

I am new at this, so all of this is a learning experience.

I started wanting to run an email server at home on a Raspberry Pi.

I started with Citadel and ran that for about a year just for my own use. Trying to upgrade to a later version and a 3b+ had issues and so I started to look around.

I found a package out of NZ called SurgeMail and messed with it for a while. 5 users at home was free, but then 10 users was $100/yr and you were supplying the server. Issues with Charter/Spectrum Residential blocking/blacklisting caused me to look around some more.

Then I found MaiB and Linode. $5/mo. Spectrum Business was way more expensive.

0.30 was all there was. Installed that on a VPS. Struggled getting it working, but with the help of a nephew, I was up and running. Main issues were with getting the domain name registrar set correctly. I was over thinking the problem.

Linode VPS provide both IPv4 and IPv6. I worked at getting all checks on the status page in MiaB. It shows IPv4 and IPv6.

For some reason the IPv6 email sends were getting bounced because they were blacklisted at Spamhaus. I did not see that until I tried to use RoundCube to send emails. It was using IPv6 on the VPS.

Bottom line… Wisdom comes from experience, and experience comes from lack of wisdom. Circular problem.

Am I happy camper? You bet. Only thing on my wish list is quotas and that is going to be fixed.

My only question is… Will the upgrade that has this install over the top of my existing install?

Dennis

EDIT: I am new to the email server world. I did industrial controls system integrations and control software. I have actually written code for the Intel 4004 by hand. I guess that dates me.


closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.