Setup fails on clean 14.04.5 install with SSL errors

I’m seeing precisely the errors described in Strange End of Setup on a completely clean install of Ubuntu 14.04.5 amd64 server with all packages up-to-date (ran “apt-get upgrade” and “apt-get-dist-upgrade”). The only non-standard package I’ve installed is qemu-guest-agent, as this is a VM.

I tried the installation twice with exactly the same result. Before running the Mail-in-a-Box setup script, I’ve confirmed apache is not installed, but once the installation fails, I see several apache packages installed. Perhaps there’s a problem with some dependencies of a package Mail-in-a-Box is installing?

I was able to complete the setup without errors after removing the apache packages and trying again, but it looks like this might be something to fix in the installation script. (Sorry, I’m still getting familiar with the setup.)

uninstall apache2 package and try again. also make sure SSH and openssl are installed.

Hey buddy, how goes it?

Might be something we should see if we can get added to the setup instructions on the webpage. Any idea who we can contact to do that?

This looks like a bug in the installation script, not something to add to the setup instructions. I did not have any Apache packages installed before running the script. It’s something the Mail-in-a-Box script itself did that caused these packages to be installed.

Hello chaos215bar2,

I don’t think it is a bug in the script, as this does not happen on a VPS I have in Germany. There is another chain on this forum where murgeo and I discuss this and after testing, this does not seem to be the case. That is what I thought first too, but we came to the conclusion that the default Ubuntu installer seems to put Apache2 onto the server after a period of time. This is something we can replicate on some VPS providers and not on others. I just now always run apt-get remove apache* every time I setup a new box for MiaB.

This always always happens on my own ESXi dedicated server, no mater what Ubuntu 14.4 install ISO I use, but never happens on my VPS in Germany. I’d love to get my hands on a copy of the install they use to test it out, but that is not going to happen.


This seems to depend on some external factors (which is very odd), but this failure is definitely consistent in my case and caused by the installation process itself.

I’m installing in a VM managed by Synology Virtual Machine Manager. I’ve restored to a state just before installing MiaB and confirmed that apache doesn’t mysteriously install itself after some time. I’ve also tried the MiaB setup multiple times and confirmed it consistently fails near the end with the same error and with the Apache packages installed. Removing all Apache packages and re-running the setup is an effective workaround, but this is definitely a bug… somewhere.

Again, the only non-default packages I’ve installed before running the setup are OpenSSH (selected during the install itself) and qemu-guest-agent, installed immediately afterwards. Neither of those should be installing Apache, especially some time after the packages themselves were installed.

I’ve narrowed it down to some time between installing Nginx, Roundcube, and Nextcloud. My guess would be one of the latter two has somehow gained an unexpected dependency on Apache?

Possible, but just uninstalling apache2 and re-running the install script for MIAB fixes this issue with other people.

I’m not sure why you’re trying to dismiss this issue. Yes, that’s a work round, but isn’t the entire point of Mail-in-a-Box to be absolutely pain free? You’ll see I found the workaround before even posting here, but having the first install attempt fail with an obscure error message (even if the solution is easy, once you find it) isn’t exactly pain free.

I created another post here because the one I linked to had been closed with no actual resolution. This setup bug certainly isn’t a showstopper, but I figured it deserved some attention (and maybe a fix) from someone more familiar with the MIAB setup then myself. Plus, the theory that something in the OS was going around installing Apache post-install was just weird and needed some counter evidence.

Hello chaos215bar2,

I don’t think either myself or murgero is dismissing this issue, however (and correct me if I am wrong here murgero) neither of us are involved in the development of MiaB. I’m just here to pass along some help if I can.

If one of the developers here want to look into this further I’d be happy to pass along my findings, as I am sure murgero would as well.


Not dismissing, but there is nothing to do until @JoshData releases the fix in the install script in a later version (hopefully the next version)

Couldn’t have said it better myself! Although I did fork MIAB to try and resolve the issue, I am not good at bash scripting.

That being said, I thought I read somewhere that @JoshData had a fix and was working on it. If I find that information, I’ll pass it along.

I haven’t started working on it. This is a real show-stopper and I feel bad that I haven’t had time to dive into it, but unfortunately feeling bad doesn’t make more time for side projects. If anyone can fix it before me and open a pull request, that’s even better.

1 Like

I’m not trying to step on anyone’s toes, but yes, those responses do dismiss my original post, when all I’m trying to do is report more information about a setup bug. Obviously that was not the intention, and @JoshData is aware of the issue. (Thanks for the response!) I believe everyone was just trying to be helpful, so thanks there too.

I can’t promising anything, but if I do have a chance to take a more thorough look at what’s going on here, I can try to at least narrow this down further.

1 Like

I appreciate the work you and your team does on MiaB. No need to feel bad about an issue that is easily worked around.

1 Like

I honestly did not think it was an error in the script. From my troubleshooting I could make it happen only using a fresh VM,and anytime I reinstalled it did not reoccur.

However I do apologize if my responses came off as dismissive. That was not my intent at all. I just wanted to get your MiaB up and running. I leave the development work to wiser people than me.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.