Setting up on scaleaway

Hello!

Im trying to setup on scaleway vps. Setup completed without any problems but they have a strange network configuration. By default server listens to private ip (which is local and not configured on server because I dont see it in ifconfig) and now all the mailinabox services listen to that ip. I have public ip too. Any configuration I need to change to add that public ip or there are other solutions?

In some strange way it started working. Maybe scaleaway support did something.

Good to hear it started working. I have two server now with them and found you have to make a few tweaks. See: https://github.com/mail-in-a-box/mailinabox/pull/754. In that PR I made a few changes to the firewall setup and /etc/default access rights. There are still some problems with the PR, it doesn’t support ipv6 yet, so it is wise to not enable that yet on Scaleway.

Also it is wise to install via github at the moment. The latest dev version also sets the hostname properly, which Scaleway doesn’t do.

It works only for receiving. :smiley:

Outgoing not working.

Can I upgrade mine to dev version or better reinstall?

Have a look at my pull request. Incoming email is probably due to the firewall settings. You need to allow smtp via de scaleway UI. After that you have to hard reboot the server from the console otherwise the changes won’t be picked up.

You don’t have to reinstall.

I haven’t tried this but it should work:
cd mailinabox/
git checkout master && git fetch && git pull && setup/start.sh

But if you don’t feel comfortable (or understand) with this you can wait for the next release. I gather this isn’t a production box yet so if you have problems you can always restart. If it does have prod data on it make sure you do a backup. That has the update to the hostname in it. There are some tweaks necessary to ufw. Best for now is to disable ipv6 in /etc/defaults/ufw.

I already turned off smtp restrictions after contacting them + did 2 reboots. No changes.

tried git checkout:
error: pathspec ‘master’ did not match any file(s) known to git.

git pull says up to date

It`s not production box. Just testing for now.

Did you do the reboot from the console? So turn of the machine and select the top option, hard reset.

I haven’t done a “normal” non dev setup in a while. I will try it out.

Just did hard reset, now it`s green in tests and working. ipv6 turned off. Thank you!

Edit: its in gmail spam because of spf records which ones I dont have?

Thanks for this topic, helped me with my Scaleway setup as well.

Can’t believe still that that server is only EUR 2,99 per month. Would cost me more if I did it at home

Sorry for the late reply. Nice that it is working. I also can’t believe the price and it is really fast.

If you want to track the dev branch it is almost easier to remove the mailinabox directory and just run git clone https://github.com/mail-in-a-box/mailinabox.git.

Otherwise you have to manually fetch the branches:

git remote set-branches --add origin master
git checkout -b master
git fetch origin
git merge origin/master

Only do that if your git-fu is strong :stuck_out_tongue: and you are know what you are doing. You can also just update the hostname like in this PR of mine (merged to dev) https://github.com/mail-in-a-box/mailinabox/pull/773

I`ll stay ith stable version for now. :smiley:

Got my own being installed as follows:

  • Set a custom (dedicated) security group for your ‘scaleway’ server as:

    22 ALLOW Anywhere
    53 ALLOW Anywhere
    25/tcp ALLOW Anywhere
    587 ALLOW Anywhere
    993 ALLOW Anywhere
    995 ALLOW Anywhere
    4190/tcp ALLOW Anywhere
    80 ALLOW Anywhere
    443 ALLOW Anywhere

  • Ubuntu fully updated with apt-get update && apt-get upgrade -y

  • Verified ufw is already installed

  • Edited /etc/hostname from box-mydomain-com to box.mydomain.com

  • Edited /etc/default/ufw by setting IPV6 to “no

  • Edit /etc/ufw/after.rules by adding a -A ufw-reject-input -j DROP line right before the final COMMIT line

  • Now, through SSH:

ufw logging off
ufw allow ssh
ufw enable
reboot

apt-get install git
git clone https://github.com/mail-in-a-box/mailinabox
cd mailinabox
setup/start.sh

  • MiaB installed with no issues and my mail server is now correctly running in ‘scaleway’ ( so far :wink: ) but will wait some days before to move it to ‘production’.

Hope this may help you & others,

rgrds & thx4all,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.