Setting up DNS on MIAB to support

I’m using a server that is setup to use I’ve modified my spf record to:

v=spf1 mx -all

Email is still being sent to spam for recipients. Do I need to modify other DNS records as well?


Send a mail to the address provided by and see what the result is …this is your first step.

It failed DMARC, which I was expecting. I wasn’t sure how to add a command that may from send grid was also acceptable, or do I need to shut off the DMARC all together?

initial result was a total fail of the DMARC records.

I heavily modified them and now I get a better result

Maybe there isn’t a way to add another sender to DMARC… I’m unable to see it on the DMARC org site

Are you actually using the DMARC reports???

It looks identical (basically) to me.

Why are you even using DMARC? Are you actually following the results sent to you? If not, I would not even publish a DMARC record. In either case, you seemingly have two DMARC records in DNS. Get rid of one!

MIAB sets up a DMARC record… how do I disable it?

as far as looking identical, the first time, my DMARC was set to the default for MIAB

v=DMARC1; p=quarantine

Not sure why it looks identical now, unless it re-queried the DNS when I hit the link again?

Ok, now your DMARC record is:

;; ANSWER SECTION: 1800 IN TXT “v=DMARC1; p=none”

The MiaB default … earlier you had two records:
;; ANSWER SECTION: 1800 IN TXT “v=DMARC1; p=none; sp=none;; rf=afrf; pct=100; ri=86400” 1800 IN TXT “v=DMARC1; p=none; sp=none;!10m; rf=afrf; pct=100; ri=86400”

Add a new DMARC record to the Custom DNS page. It will then replace the default record.