Sent mail goes to Gmail's spam


#1

Dear all,
To make a long story short - I love mail-in-a-box, I’ve installed in more than a year ago, but practically I can’t use it because I can’t get it to do the most important thing - sending emails. I understand this isn’t MIAB’s fault. I’m just wondering, before giving up the fight and going with FastMail/GSuite/etc’ , if there’s something I can still try and do, or are everyone at the end of the day are crossing the fingers when they press “send” from MIAB?

My domain and all are set correctly. The IP (Linode) isn’t blacklisted. I have DNSSEC set correctly. But still, when I send an email to any of my friends (99% use Gmail) - it goes to their spam.

Looking the other messages here - I doesn’t seem like I’m the only one, but I wonder if everyone are facing this issues and we just don’t like talking about it, or maybe there’s one more trick I should try.

Any suggestions? I’m honestly quite frustrated and have spent so many hours on this already.

p.s. https://mailinabox.email/slack/ doesn’t seem to work (gives me 502 bad gateway)

Thank you very much. I love this piece and software and it sucks that big corps are making this unusable.


#2

If your domain was new during it’s first setup of MX records (even if a year ago) you will need to verify the ownership of the domain to prove you are not a spammer.

I see you did some digging in the forums, I am surprised you didn’t see the solution to login to google and verify the domain.


#3

Thanks @murgero . If you mean the verification process at https://gmail.com/postmaster/ , I’ve done it a few days ago. My messages since then still go to spam.


#4

I even spoke to a Gmail employee about this and he just kind of shrugged.


#5

Before giving up the fight, I would try using an external SMTP relay first. Granted, I have not done so personally as I am not facing the issue but it is worth a try. Keep in mind it is an unsupported modification so it will be necessary to make the config changes each time you upgrade MiaB … but it may help as a temporary solution at least.

Care to share your box’s hostname? Sometimes having another set of eyes can help find something that is not overly obvious. I also remember what when I did the postmaster tools verification with Google it seems that it took a few days to a week to really see results.


#6

Thanks @alento! My hostname is yoavmoshe.com . I’ll wait a couple of days to see if the Google postmaster tools show something. Regarding using a relay - maybe I’m miss understanding it, but does’t that mean that I need another email service provider then, to send the emails through it? I think that defeats the purpose of using MIAB, no? Or did I not understand the idea?

@Ruseen - I’m not surprised. I mean, it definitely works just fine for them to make email more and more centralized.


#7

Have you tried sending test emails to places such as:

http://dkimvalidator.com/


#8

Tried a couple of other services before with no luck… Just tried this one too - everything seems fine - all passed and SpamAssassin score is 0.478. You can see the full results with o9lvxgehj25cok@dkimvalidator.com and pcpyzixdbrbkmj@dkimvalidator.com .


#9

It can take a couple weeks, though it didn’t for me. I know that my server emails do not go into gmail spam after some time, and doing the verification in postmaster.


#10

I am facing the same problem.
But for me even Yahoo and Gmail both are considering as spam!

Yes, my domain is brand new which I have created just for MIAB . My DO IP is not blacklisted!

While google original email show all as PASS - still mail going into spam

|SPF:|PASS with IP
|DKIM:|‘PASS’ with domain
|DMARC:|‘PASS’ Learn more|

Testing with https://www.mail-tester.com/ produces 9.5/10

Even https://postmaster.google.com have not been verified since 1 week -

My question is if I keep on using this new domain - will google start recognizing in later future and not mark it as spam?

Or any other solution that could help in getting out of spam box.

Thanks ,
Manish


#11

Verification is usually instant once you have updated DNS with the required TXT record. I suggest that you re-do the verification process.

Yes. It took somewhere between 2-3 months on one of my MiaB instances to completly clear up. Others a few days. I do not think that there is a rhyme or reason known to anyone but Google’s AI.

Yahoo also has a program similar to Google’s Postmaster Tools and Microsoft’s Junk Mail Reporting Program but I do not know the specifics off hand as I have not had a problem with Yahoo.


#12

Thanks for the reply @alento

I have tried various times adding both TXT record as well as CNAME - but no help :confused:

Can I just do like I will use MIAB to just receive mails and use AWS SES to send emails - does that helps in terms of improving the reputation of my domain?


#13

Yes, that is an option. It is an unsupported modification but one that you can make. However when doing so, you may need to re-do the modifications whenever MiaB is updated as those modifications are generally overwritten by the install script. It will not improve the reputation of your IP though as you won’t be actually sending from your IP.


#14

Go it. Just trying to get started to send email. I will use AWS SES via smtp to send emails for the time being, till MIAB issues get solved.

Thanks.