Secondary nameserver with Buddyns failed


#1

Hi,

I am trying to get BuddyNS as a second nameserver but whatever I do I get an: “AXFR queries FAILED” while trying to enable AXFR transfer to BuddyNS.
Unfortunately the tutorial from m4rcs is not longer available on the schiller.im website. Does anyone have a copy of the tutorial or can anyone point me in the right direction?

Thanks,
Roddy


#2

You could use Puck.nether and/ or 1864 instead. Both are FREE, too


#3

I too would love to see this original guide, so if anyone has it saved/archived, please share. I am considering creating a replacement but haven’t found the time to test everything yet.


#4

I think the problem is not with BuddyNS but my box which keeps failing the transfer to any secondary server.
Tried several options in /etc/bind/named.conf.options but no change.


#5

SOLVED.

This worked for me, now my DNS transferred correctly to BuddyNS.
On your MIAB go to Custom portal, System, Custom DNS, Using a secondary nameserver
Hostname:
j.ns.buddyns.com xfr:173.244.206.26 xfr:88.198.106.11 xfr:108.61.224.67 xfr:103.6.87.125 xfr:185.136.176.247

where j.ns.buddyns.com can be found on https://www.buddyns.com/support/setup/zone-delegation/
and all the ip addresses on https://www.buddyns.com/support/setup/zone-transfer/.

From the same page on the MIAB:

To enable zone transfers to additional servers without listing them as secondary nameservers, add xfr:IPADDRESS

This will adjust the /etc/nsd/zones.conf file on your box.

Good luck


#6

How is the second name server listed at your registrar? Is it j.ns.buddyns.com or ns2.box.yourdomain.com?


#7

j.ns.buddyns.com.

At my registrar you can list 8 nameservers but I just listed 2:

Nameserver: ns1.box.yourdomain.com
Nameserver: j.ns.buddyns.com

BuddyNS offers a paid Vanity DNS so you can use ns2.box.yourdomain.com.


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.