Rsync backup issue


#1

Found an issue with my RSYNC

Moving from 0.28 to 0.29 …

under 0.28 evertything was running fine, I updated … than it happened. But it is unsure what is the cause
rsync does not work anymore due 2 probably 2 events

  1. My target machine got an abrupt shutdown (house lost its power for 8 hours)
    due to this my shh known_host was not the same anymore after a reboot. that was fixed quick.

But now I do not see my old backups anymore as mailinabox tells me there is something wrong

  • I have rsync running on a non standard SSH port. I have changed port 22 to 1234 on line 19 of backup.py
    This port was back to its default after the new version was installed.

  • When I press ok in de admin section of mailinabox I see on my target machine
    that I have a valid session

12:19:32 host sshd[26666]: Accepted publickey for user from 1xx.xx.1xx.xx port 56327 ssh2: RSA SHA256:SSketc
Nov 2 12:19:32 host sshd[26666]: pam_unix(sshd:session): session opened for user myname by (uid=xx)
Nov 2 12:19:32 host sshd[26666]: Received disconnect from 1xx.xx.1xx.xxx port 56327:11: disconnected by user
etc.
Than I need to see the content of my previous backups, but I do not get any data

I tried to start
management/backup.py
but no feedback on screen
from the available backups I get the feedback: Something went wrong, sorry.

When I ssh with the command:
ssh -i /root/.ssh/id_rsa_miab user@domain -p 2244 all is working fine from the box

I wonder why there is no feedback on the listing of the backup files, cause I cannot see or find the reason why I would see ‘Something went wrong sorry’


#2

Actually …
I see that the backups are made

So the issue is now:
Why do I not get a list with backups made? with the message ‘there is something wrong’