Roundcube - issues with one specific settings page - all accounts "loading" / unable to "save" modifications

I am having an issue with Roundcube webmail that is bugging the hell out of me - I somehow have one single page of settings, “Mailbox View” that won’t load correctly - displaying 'Loading…" for over a minute . The “save” button remains gray.
This issue effects all accounts.
All other settings pages perform fine. I have restarted the server several times (for other reasons) and am still experiencing this. Happy to provide logs or answer questions in pursuit of resolving this.
I am aware this may need to get directed at Roundcube’s board, but figured I’d try here as well!

1 Like

i have exactly the same problem. as a workaround i pretend not to need any of those settings. the rest of roundcube/miab works perfectly. some googling/searching for this error at the roundcubeforum didn’t help me figure out whats wrong… :frowning: noone seems to have this problem. can anybody repoduce this error on a fresh installation?

Well, dang. I completely nuked and paved; second go-around I was able to configure the preview pane as desired for two users, but by the time I got to the third the issue had already come back from the dead! Exact same symptoms as before. Super weird. Please do reply here if you find a solution beyond pretending it isn’t happening @beyondthewall ; I will do the same

hi, since i wasn’t the only one with this problem anymore i gave google another shot :smile:
i found out the trouble was the html5_notifier plugin for roundcube. (it allows you to get nice notifications in your browser)
i simply deactivated the plugin sinse the notifications weren’t working anyways and the settings page worked fine again. (of course with the notification settings missing).
following command disables the plugin:
sudo chmod 700 /usr/local/lib/roundcubemail/plugins/html5_notifier/

hope this helps!

edit: i tried to download and install the latest html5_notifier plugin though its original site is down: (maybe it has been discontinued)

Woot thanks @beyondthewall , worked instantly.Thanks much!

I suspected the plugin on this github issue: Perhaps we should upgrade it.

I see you tried upgrading. Sorry, bit quick on the reply :wink: Perhaps we should remove it from the install.

The github repo is online. I can’t reproduce the problem. Could you try to change the hash on this line: to 87817f15648e8ed7f2c1ad5ef00286c7a2a61155.

Then rerun the setup. If that works, we can create a pull request to solve the issue.

Here is the repo:

hi, i changed the version and reran the setupscript. it did update though roundcube still hangs in mailbox view.

Thanks for the effort! We should probably disable it in the installer until it is fixed and raise a bug in the upstream repo.

just two hours ago another new version of html5_notifier was released on github ( and i changed the hash to 4b370e3cd60dabd2f428a26f45b677ad1b7118d5 reran the setupscript again and tada! it works! this solves the hanging problem for me :smile: :thumbsup:

thanks so much for this! seems i gave up on finding the repo too soon.

Great! Thanks for putting in the effort. Do you feel comfortable raising a pull request on the miab github repo? Or would you like me to do that?

to be honest i’ve never opened a pr before though if you don’t mind i’d like it to be my first :wink:

1 Like

Your first pr, may many more follow!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.