RoundCube filters not working after folder reshuffle

Hi everyone.

First off - thanks to the developer and forum members for making the dream possible! My MIAB has been running flawlessly for a couple of years, without any effort on my part.

However, after having moved my RoundCube folders from under the Inbox folder, all my existing filters no longer work and neither do any created subsequent to the folder move. I’ve tried moving folders back under the Inbox folder but new and old filters still don’t work.

I don’t think it’s related, but this have happened just after a recent migration to a new box (from ubuntu 18 to 22). I’m 99% sure the filters were working after restoring the backup.


I found this solution but couldn’t find the file and am reluctant to delete files willy-nilly. Resolved - Roundcube filter not working | Plesk Forum

I tried deleting my_account.svbin file (in home/user-data/mail/sieve/my_domain_name/). Rebooted and a new file was created but did not fix the issue.

sieve.log file shows

sieve info
error msgid=<bounce-(an email address)>: failed to store into mailbox ‘my_mybox’: Mailbox doesn’t exist: my_mailbox.

bump. Anyone got any ideas?


User error when reshuffling folders. I recreated folders in the new positions but did not update the RoundCube filters correctly to point to the new folders/folder locations. Hence the errors.

Update each existing filter in RoundCube.
(Go to settings, filters, actions and from the dropdown box select the new folders - Note - if the new folder names are identical to the old ones, make sure you point to the new folders)