[Resolved]Trouble with administrator@mydomain alias

I’m going through StartSSL to get an SSL cert and part of the validation process is e-mailing postmaster@mydomain.net. According to my aliases this should forward to adminstrator@mydomain.net but this doesn’t seem to be forwarding to my admin account of the server.

I’ve tried changing the administrator@mydomain.net alias to forward to my admin account, but it kicks back an error that says, “This alias can only have administrators of this system as destinations because the address is frequently used for domain control validation.”

Is there a different way I need to login to get to these e-mails? The rest of my setup has gone flawlessly, just feel like I’m probably missing something horribly obvious here.


If you email postmaster@ (preferably from an email address not hosted by your box), do you get the mail?

I tried e-mailing postmaster and administrator from my gmail account and it bounced back undeliverable both times.

I was able to successfully send mail to the (administrator) account I set up in the initial installation however, so I know the server is capable of receiving mails, or at least, mail from gmail. I even did a follow up after the postmaster and administrator e-mails bounced back and I was still able to receive mail at my initial account.

Alright, well, as weird as it sounds, 24h later I was able to add my admin account onto the administrator and postmaster aliases. No idea why it suddenly let me do it whereas before it was denying me, but, there it is.

I did not reboot, or otherwise alter the server in any way. Not sure what happened in the background but I’m glad it did!

Thanks again for the awesome mailserver!