[RESOLVED] Owncloud posts a 404 all the time, without fail

When trying to log into Owncloud on my box, I’m noticing that Nginx is posting a very boring-looking 404.

When digging a bit deeper, the Nginx log shows the following:

2015/02/18 00:14:45 [error] 7967#0: *18 FastCGI sent in stderr: “Primary script unknown” while reading response header from upstream, client:, server: box.domain.tld, request: “GET /cloud/index.php/apps/contacts/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “box.domain.tld”, referrer: “https://box.domain.tld/admin

I’m not quite sure where the best place to get started to search and repair, but I’d be interested in any thoughts. I have, though, tried running the bootstrap script again, to no avail.


Figured this one out. Turns out that the logical volume serving Mail-in-a-Box filled up half way through the install, leaving the install in a half-completed place.

That stated, going back to the base install snapshot, fixing LVM, and re-running the kickstart script worked.

Though I would’ve loved to figure out the root cause, this was the quickest solution.