Recipient address rejected, the box is confused

I have set up a Mail-in-a-box over at DigitalOcean and all worked perfectly. Mail-in-a-box is way over its competitors!

Though … I have an issue:

  1. I added an email address [] - which was not the admin [the admin was]
  2. points its MX to google, it’s something completly different.
  3. when I wanted to send [from Mail-in-a-box] to, the email got sent to the box’s account, not to google.
  4. I deleted from the box’s interface and the files from /home/user-data/mail/mailboxes/
  5. now when I try to send to the email gets rejected.

I think that the box thinks of itself as being the destination for, but seing that it has no user it just rejects the emails.

I know there must be a way to delete the seting that makes the box think it’s the intended destination for email sent to, but I just couldn’t find it. This happened when I added the address to the box.


This is when there are any users or aliases entered for that domain name. Depending on your DNS, this may also affect DNS so you may have to wait 30 minutes for DNS to clear.

You are right, I still had the aliases set to Changing them and rebooting the machine solved the problem!

Thank you so much! :smile: