Re-install after delete /home/user-data/


First, thank you for the job.
I was very happy to find a complet package to fit my needs… and easy to improve/hack!

The problem, the /home/user-data/ was deleted (problem with LUKS), bad luck.
And I reinstalled on the server but all SSL certificates are wrong.

I don’t know how to reset them. not working

Should I reinstall the server? or you have a way fix the problem?

Have you tried re-running sudo mailinabox?

I done a reinstall of mailinabox but I still have problems with certificats

What do you mean by sudo mailinabox ?
It’s a special command ?

Thank you, the command sudo mailinabox reset software but don’t remove the users and domains…

When I do to the web interface, I can login but after a message:

`Something went wrong, sorry.


This command is to be run in the terminal, not through the GUI.

I run the command on a console sudo mailinabox

After when I go to the web interface. I can login but after a message:
Something went wrong, sorry. OK

Where I can find the logs of this web interface? Because, I have nothing in the nginx logs.

This is on Ubuntu Server 18.04 without anything installed other than MiaB?

It’s a fresh install with Ubuntu Server 18.04 and after MiB

Is this a VPS? If so, who is the provider?

This a VM on a PROXMOX. It’s a VPS with a static IPv4.

There is nothing altered from the Ubuntu 18.04 image?

If so, I would say the best bet is just start over and reinstall. As best I can tell, all of the install data that matters is in /home/user-data/, so you have little to lose and it may take less time than trying to resolve whatever your issue is.

Ok thanks for your reply.
I will do on sunday morning… less mail trafic!

Delete the contents of the /home/user-data/ssl/ directory.
then re run sudo mailinabox.

Remember, delete the CONTENTS only - do not delete the /ssl directory itself.

Done, the SSL certificate for the HOSTNAME was regenerate.
But I think the problem is the other mail domain are not present and the admin interface is “lost”.

The admin interface was “lost” because I add an wrong aliases!

Thank you for your help (the feedbacks help me to understand MiB).

First :



✓ All system services are running.
:heavy_multiplication_x: The SSH server on this machine permits password-based login. A more secure way to log in is using a public key. Add your SSH public key to $HOME/.ssh/authorized_keys, check that you can log in without
a password, set the option ‘PasswordAuthentication no’ in /etc/ssh/sshd_config, and then restart the openssh via ‘sudo service ssh restart’.
✓ System software is up to date.
? You are running version Mail-in-a-Box v0.44. Mail-in-a-Box version check disabled by privacy setting.
✓ System administrator address exists as a mail alias.
✓ The disk has 92.41 GB space remaining.
✓ System memory is 33% free.


✓ Firewall is active.
✓ Outbound mail (SMTP port 25) is not blocked.
✓ IP address is not blacklisted by
Traceback (most recent call last):
File “./”, line 976, in
run_checks(False, env, ConsoleOutput(), pool)
File “./”, line 64, in run_checks
run_domain_checks(rounded_values, env, output, pool)
File “./”, line 301, in run_domain_checks
mail_domains = get_mail_domains(env)
File “/root/mailinabox/management/”, line 266, in get_mail_domains
+ [get_domain(address, as_unicode=False) for address, *_ in get_mail_aliases(env) if filter_aliases(address) ]
File “/root/mailinabox/management/”, line 266, in
+ [get_domain(address, as_unicode=False) for address, *_ in get_mail_aliases(env) if filter_aliases(address) ]
File “/root/mailinabox/management/”, line 251, in get_domain
ret = emailaddr.split(’@’, 1)[1]

=> Problem with an alias:
`sqlite3 /home/user-data/mail/users.sqlite

select * from aliases;



And now, no more bug!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.