Problems with IPv6 on server with no IPv6


As a couple of people pointed out earlier: When the IPv6 is tuned off (or not supplied by the cloud provider in my case), the config file that MIAB creates (and re-creates) for nginx has it listen to IPv6 thus preventing it from starting. Even when the nginx config files are manually corrected to have it not try listening on the existent IPv6, it’s just a matter of time until it’s reverted back to the original version by MIAB.

So here is the question for the experts:
How can we configure MIAB to not re-write the original config file after it has been manually modified, or alternatively, have it not include listening to IPv6 in its future re-writes of the config file?


You are fighting an uphill battle, my friend. IPv6 is certainly the future and while you may delay the inevitable, more and more services are going to be using IPv6 functionality, along with all the inevitable bugs and problems that go along with that.

What cloud provider are you using that doesn’t provide an IPv6 address???

In the mail server world, IPv6 is truly optional. There are many major organizations that do not publish aaaa records for their mx hostnames.

VPS hosts may make IPv6 optional. The Mail-in-a-Box Setup Guide recommends disabling IPv6:

If you have a choice, choose a location for your machine that is near you — it’ll be faster! And if disabling IPv6 is an option, disable it.

Although that was published before Fail2ban supported IPv6.

1 Like

I have friends in Austria and the server there rejected my email because I didn’t have an IPv6 addressed assigned to my MIAB server. I set it up and mail went through.

Perhaps it is a unique experience but it certainly forced my hand to assign an IPv6 address. Been working fine ever since.

They can’t email a address.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.