Problems upgrading to V60

I upgraded from Ubuntu 18 to 22 and installed V60 (I see now this isn’t recommended).

I’m fortunately still able to receive and send mail from my phone, but trying to access results in some DNS error: DNS address could not be found.

The setup script mailinabox printed some errors:

sudo: unable to resolve host Temporary failure in name resolution
setup/ line 9: 68519 Aborted (core dumped) “$@” &> $OUTPUT
FAILED: /usr/local/lib/mailinabox/env/bin/pip install --upgrade pip

Could not find platform independent libraries
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to [:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ModuleNotFoundError: No module named ‘encodings’

I’m a little confused by this error. Regular pip seems to work fine, but /usr/local/lib/mailinabox/env/bin/pip produces this error. Anyone have any suggestions?

I would suggest creating a new VM and copying your /home/user-data/ out to it, and then running the install script.

Hi Sketch, I also opted to do an in-place upgrade from 18 to 22 and then an install of v60. It was a bumpy ride but I’ve got it going now, and I saw this same problem. To fix it:

# Enter mailinabox bin directory
cd /usr/local/lib/mailinabox/env/bin/

# Rename provided binaries
mv pip3 pip3-old
mv python3 python3-old

# Symlink in system binaries
ln -s /usr/bin/pip3 pip3
ln -s /usr/bin/python3 python3

# Install again
sudo mailinabox

I received the same message: " sudo: unable to resolve host Temporary failure in name resolution"

Going from Ubuntu 18 → 22.04.

Tried restoring backup both before and after the first install of v60. I received the same DNS resolution error.

Tried renaming the host name to box2… Same error message.

For the time being have reverted back to my v57a install and will wait a bit longer to see if there is a bug to work out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.