Problems installing on Ubuntu 14.04.5 LTS - dependencies install failure


#1

Hi all,

On attempting to install, I can not continue further than below:

Updating system packages...
Installing system packages...
Initializing system random number generator...
Firewall is active and enabled on system startup
Installing nsd (DNS server)...
Installing Postfix (SMTP server)...
Installing Dovecot (IMAP server)...
Installing OpenDKIM/OpenDMARC...
Installing SpamAssassin...
Installing Nginx (web server)...
Installing Roundcube (webmail)...
Installing Nextcloud (contacts/calendar)...

FAILED: apt-get -y -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confnew install dbconfig-common php5-cli php5-sqlite php5-gd php5-imap php5-curl php-pear php-apc curl libapr1 libtool libcurl4-openssl-dev php-xml-parser php5 php5-dev php5-gd php5-fpm memcached php5-memcached
-----------------------------------------
Reading package lists...
Building dependency tree...
Reading state information...
dbconfig-common is already the newest version.
curl is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-openssl-dev : Depends: libkrb5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried installing these packages manually:

root@mail:~/scripts# apt-get install libcurl4-openssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-openssl-dev : Depends: libkrb5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@mail:~/scripts# apt-get install libkrb5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libkrb5-dev : Depends: krb5-multidev (= 1.12+dfsg-2ubuntu5.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@mail:~/scripts# apt-get install krb5-multidev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 krb5-multidev : Depends: libkrb5-3 (= 1.12+dfsg-2ubuntu5.2) but 1.12+dfsg-2ubuntu5.3 is to be installed
                 Depends: libk5crypto3 (= 1.12+dfsg-2ubuntu5.2) but 1.12+dfsg-2ubuntu5.3 is to be installed
                 Depends: libgssapi-krb5-2 (= 1.12+dfsg-2ubuntu5.2) but 1.12+dfsg-2ubuntu5.3 is to be installed
                 Depends: comerr-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Perhaps this is a Ubuntu problem and not mailinabox, can anyone give some advice on what to do?

P.S My experience is mainly with CentOS/RHEL, so I could easily just be missing something.

Thanks.

Andy


#2

What’s in your repos list?

/etc/apt/sources.lost AND /etc/apt/sources.list.d/*


#3

In /etc/apt/sources.list:

###### Ubuntu Main Repos
deb http://au.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse

###### Ubuntu Update Repos
deb http://au.archive.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse

Files inside /etc/apt/sources.list.d/ dir:

-rw-r--r-- 1 root root 426 Mar  8 13:19 mail-in-a-box-ppa-trusty.list
-rw-r--r-- 1 root root 354 Mar  8 13:19 mail-in-a-box-ppa-trusty.list.save
-rw-r--r-- 1 root root 124 Mar  8 13:19 ondrej-php-trusty.list
-rw-r--r-- 1 root root 124 Mar  8 13:19 ondrej-php-trusty.list.save

#4

What is in ondrej-php-trusty.list that looks like it’s overriding some PHP packages.


#5

That’s us:


#6

mail-in-a-box-ppa-trusty.list:

deb http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mail-in-a-box/ppa/ubuntu trusty main

ondrej-php-trusty.list:

deb http://ppa.launchpad.net/ondrej/php/ubuntu trusty main
# deb-src http://ppa.launchpad.net/ondrej/php/ubuntu trusty main

#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.