Problem with Postfix recipient_delimiter

First things first. Josh, thank you for building a long-needed tool. It’s a great gift to many like me who just don’t know how operate our email independent of the free (personal information pimps) providers and the shared hosting (blacklisted again) companies. I hope you’ll continue to have time to keep improving it. As soon as I can get it working, I’ll start pointing others to MIAB.

I’m new this level of detail, so thanks in advance for your patience.
I edited /etc/postfix/ on my MIAB server to the following:

recipient_delimiter = -

I did this because I realized it’s simple for spammers to strip the +tags from their lists, undermining the value of the tags. Since hyphens/dashes in email addresses are usually valid, it’s harder for the spammers to determine if they’re being used as tags.

I used this article as a reference:

And, it seemed from Josh’s response to another post that it just might work.
May 15
Postfix settings won’t get overwritten.
(Sorry. The system won’t allow me to include the link to the post. You can find it by searching for the title “Custom postfix config / always_bcc”)

This was my first time using VIM, yet another minor adventure in linux. :smile:

I took the following steps:

  • Confirmed the +tag worked on the admin email address before making any changes.
  • Edited and confirmed it was saved, by using the cat command.
  • Ran mailinabox on the server.
  • Confirmed wasn’t changed, by using the cat command.
  • Rebooted the server.

Perhaps I don’t understand, but I was expecting the new delimiter setting to function like the old one. Instead, the mail was undelivered because “Status: 5.1.1 User doesn’t exist:” I also tried the +tag again, delivery failed, “Status: 5.1.1 (Remote SMTP server has rejected address)”

Did I miss another step or setting necessary for the alternate delimiter to work? I haven’t changed it back yet, because I’d really like to see this work.

Thanks again.

1 Like

Hey, thanks.

I’m happy to see the box used for learning and experimentation. That said, you are discouraged from actually modifying the box because I can’t provide support for it. Once you make a modification like this you are on your own if you have other problems.

Also, a better place to ask questions like this might be on the postfix mail list, or ServerFault – a place for general systems administration questions.

I know this is a little old, but is there anyway to use a “-” as a delimiter instead of the plus? I noticed when trying to use the plus sign as a delimiter it was rejected from the bank that i use email address update form. I was trying to do something like and it didn’t like that. I think a “-” would be safer to use since it would be expected as a usable character in an email address, maybe even a dot.

Please let me know if it’s possible and how to do it without breaking the box.

i don’t know if this would be sufficient to you but as a workaround for the trouble with your bank you could just use an alias ( and move incoming mails to a subfolder in your inbox using a sieve filter rule. you can edit/create sieve rules via roundcube - settings - filters.

It would be nice to have the ability to have on the fly aliases so that you have less to manage in the admin. The “-” feels more natural and cleaner than the “+”.

I was hoping to get feedback from you regarding the “-” vs the “+”. i prefer to stick with the vanilla install of MIAB and don’t want to make any changes that would break it or required me to have to modify every time a new version is out. Is it possible to have both + and - so that you can use either one?

I prefer that too!

As you know, the box is configured to use “+”.

Any chance on this changing in the future and making the “-” the default tag character? I’m sorry to bother you with this, just thought it would be more useful to reduce services who reject the “+” character.

That would break every existing installation, so it’s highly unlikely.

Hi Josh,

Sorry for resurrecting an old thread but as someone looking to migrate from an old qmail installation to mailinabox, this issue is very important. I’m willing to implement whichever solution would be preferred to add support for this in mailinabox.

According to the postfix documentation, it is possible to define multiple recipient delimiters.

# Handle both Postfix and qmail extensions (Postfix 2.11 and later). recipient_delimiter = +-

Do you see any drawbacks for implementing this configuration change by default in mailinabox?

Thanks for your great work!


It changes the behavior of who gets what mail, so that’s a drawback.


I came across a post on superuser and I decided to give the solution a try. It seems too simple. I’ve just started testing this today, but so far results are promising. I wanted to share it with anyone else interested so we can put it through the paces and determine if we’ve found a solution to the limited delimiter matter.

Here’s the link to the original article that prompted the request:

And, here’s the link to the promise of a solution:

I don’t know how to write scripts, so if it works, my game plan is to open the two files and change the entries as needed after every update and upgrade. It’s a painful workflow, but the payoff in having a better delimiter is worth the effort.

A sincere, “Thank you,” to Ingo Struck who actually discovered the solution.