Problem creating Letsencrypt TLS certs for two new sites

I have come across a problem when my MailInABox installation tries to create a TLS certificate for a new site, or when I try to create the certificate from the ‘Provision’ button on /admin. I have followed the ‘Something Went Wrong’ section. I have got the ‘all clear’ from the system status checks. This is the first time that I have had this problem. The last time a certificate was renewed for older sites was before the latest version of MiaB (v0.26) was installed two days ago.

The message found at the end of the output when running ‘sudo mailinabox’ and before the ‘Your Mail-in-a-Box is running’ is:

Installing Mail-in-a-Box system management daemon…
Installing Munin (system monitoring)…
Incorrect username or password
Incorrect username or password
Traceback (most recent call last):
File “management/”, line 803, in
File “management/”, line 446, in provision_certificates_cmdline
status = provision_certificates(env, agree_to_tos_url=agree_to_tos_url, logger=my_logger, force_domains=force_domains, show_extended_problems=show_extended_problems)
File “management/”, line 331, in provision_certificates
File “/usr/local/lib/mailinabox/env/lib/python3.4/site-packages/free_tls_certificates/”, line 64, in issue_certificate
agree_to_tos_url, validation_method, acme_server, logger)
File “/usr/local/lib/mailinabox/env/lib/python3.4/site-packages/free_tls_certificates/”, line 112, in validate_domain_ownership
File “/usr/local/lib/mailinabox/env/lib/python3.4/site-packages/free_tls_certificates/”, line 314, in create_client
key = load_or_generate_private_key(account_key_file, log)
File “/usr/local/lib/mailinabox/env/lib/python3.4/site-packages/free_tls_certificates/”, line 337, in load_or_generate_private_key
from acme import jose
ImportError: cannot import name 'jose’
The management daemon refused access. The API key file may be out of sync. Try ‘service mailinabox restart’.

I tried ‘service mailinabox restart’ without success.

When I try to create the certificate from the ‘Provision’ button on /admin there is a message in syslog that ends in the same ImportError from the same function as above.

I have searched this discussion forum without finding anything similar. I’d appreciate help in finding the solution to this problem.

0.26 is a very buggy release, for this I’d recommend manually importing for now.

That’s disappointing, to say the least. When can v0.27 be expected, hopefully with less bugs? Is there a way to rollback to v0.25?

I am new and only just managed to install Mail-in-a-box today having found the solution to the “failed to install” on here THANKS wish I had googled earlier in the day. (used the $ git checkout e7150e3) version

Logged in to mail-in-a-box just fine on my IP - lots of green ticks after a couple of distro updates and rebooot.
I went to install SSL using LetsEncrypt.

DISASTER! now I cannot log on to mail-in-a-box "Something went wrong, sorry"
Any suggestions how to recover? What went wrong?

Edit: [SOLVED] by the v26b update (the e7150e3 obviously an interim) - easy

After installing v0.26b and a server reboot, I am pleased to report that the problem detailed in my OP above has been cured. Many thanks!