PHP Not working

I believe that I have rigorously followed the suggestions given in this link and have read multiple posts on here most of which are ancient and apply to much older versions of MIAB

Still no joy seeing the info.php file in the browser. In fact even worse it tries to download the file by opening file save in the browser window when pointing to the file.

The index.html file in the same directory still works perfectly but the index.php file just does the same as info.php

Yes I’ve done a

sudo service php5-fpm restart


sudo service nginx restart

so you have opened and it does not work?

No index.php just give a blunt 404 message (I think that is the one I saw in one of those files) anyway a 404 just implies that it doesn’t understand PHP. Same result with the info.php file created as per those instructions. And even a 404.php file I placed there.

The index.html still works - so it is not an issue of not seeing the directory.

404 is file not found, not file not processed…

can you PM me the direct link to your site giving the error (like