OS X client email setup failing


#1

Hello there.

I am having some difficulties setting up my iPhone and OS X email clients.

On the phone, emails can be received, but not sent. On the desktop, setting up the mail account manually fails with a “SASL PLAIN authentication failed” message and sending from the phone an aborted authentication failed “method=PLAIN” message in the /var/log/mail.log. I can send and receive just fine through the web client (Roundcube).

I’ve scoured as many forum topics and websites as I could and I’ve seen various different explanations - not the least of which being that it takes some time for DNS changes to propagate. I’m stumped.

Any advice for where to look for clues next?


#2

What comes to mind is that mailinabox does not authenticate using plaintext passwords. That is just bad security, if it did.

Have you tried other methods of authenticating in the list?


#3

MIAB will use PLAIN as it is over a TLS connection… that said

OP - Have you used the OSX autoconfig found under the instructions tab in admin panel?


#4

I did. It finally passed initial tests when I added the profile (using the auto-config file) and ignored the password fields. But the minute I had to authenticate to send-and-receive mails, I was back to square one and the authentication errors in the log file.

On IOs, I had a little more luck. I entered the passwords and they were accepted in the Settings app. I can receive emails on IOs too, but … PLAIN text authentication errors on send as well.

I thought maybe it’s because it’s not asking me for additional configuration options (STARTTLS for instance) but I can’t find those options in settings anywhere. I even looked through the auto-config file to see if I could understand what it was doing. It’s a simple XML file with details anyone could guess from mail-in-a-box requirements and publicly available details about the instance itself.

The only thing I haven’t tried is running the configuration again.


#5

It’s morning here. I decided to simply try changing the password. For some reason, that worked. I wish I knew why though - I used the same characters in the new password save for one (asterisk). All I am left with is that somehow the initial password just wasn’t matching for some quirky, ghost-in-the-machine reason.

/shrug

Thanks for your patience all.


closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.