Opening up a custom port for SSH after install

I use a custom port for SSH.

After installing Mail-in-a-Box I was no longer able to SSH into my server as the firewall was blocking the port.

Thankfully I’m using DigitalOcean and was able to use their virtual console to SSH into the server and sudo ufw allow 1330; reload ssh to reopen the port.

So if you are using a custom port to connect with SSH, make sure you open up the port after installing Mail-in-a-Box before you exit the session and close the terminal.

Was this a Digital Ocean option or did you modify the box before starting the setup?

No I modified the box first.

The first thing I always do when spinning up a new droplet is to add a bit of security to the box:

adduser ubuntu
usermod -a -G www-data ubuntu

vi /etc/sudoers
	ubuntu  ALL=(ALL:ALL) ALL

vi /etc/ssh/sshd_config
	Port 1330
	PermitRootLogin no
	PasswordAuthentication no
	UseDNS no

reload ssh

Thanks. It should now automatically open that port too: