Nsd via ipv6 on port 53 not reachable cont

Just fyi, I experienced the issues described in


and the reported fix solved them. In my case, nsd just stopped listening on IPv6 port 53 and came back after I added “port: 53” to nsd.conf. Maybe its random, but certainly inconvenient (difficult to identify for beginners)

Would you be so kind as to report this issue and your resolution on the MiaB GitHub repository?


I’ve literally just had this problem and in nsd.conf, it was binding to an autoconfiguration ipv6 address. I disabled autoconfig ipv6 in systemctl and rebooted which resolved my problem.

sudo sysctl -w net.ipv6.conf.all.autoconf=0