NSD Logging disabled?


#1

Hello,

Currently NSD logging is (as best as I can tell) disabled.

The first line of /etc/nsd/nsd.conf says not to edit as it’s overwritten by MIAB.

Is it possible to edit this file to enable logging, and if not, how can NSD logging be enabled?

I’d like to check the logs for API connections.

Thanks!


#2

Hi houseecaz,

Probably you’d figured this out by now? But this may help somebody else as… I was in a similar position thinking that as well and trying to “enable” logging for nsd.

NSD is not very chatty but it logs in to the syslog:

deploy@box:~sudo grep nsd /var/log/syslog*
/var/log/syslog:Feb 12 16:26:29 box nsd[3589]: SIGHUP received, reloading...

Also if you have enabled secondary NS “slaves” ( or allow transfers,test check xfr:IP) under:

https://box.example.com/admin > System > CustomDNS > Using a secondary nameserver > Hostname
You should see any failed or successful transfers to the slaves if any zone changes occur.

However, It does not seem to log if I add my router external IP - xfr:IP and use dig to test:

dig axfr @ns1.box.example.com example.com from behind my router.

I can get full zone details from NSD for example.com but this is not logged in syslog.

Cheers,