No incoming e-mails in new installation


I’m new to MiaB and installed it (v56) on a new VM running Ubuntu 18. I made sure that all ports listed in ufw status are available for all IP’s (both IPv4 and IPv6, TCP and UDP). DNS was altered 24h+ ago, so that’s not an issue.

I have configured a mail user and set up everything for outgoing e-mail. It got a 10/10 from mail-tester after some finetuning, so that’s great. Sending e-mails is not an issue, it works great.

The issue is that I’m not receiving any e-mails. Not to a user that has been created, and not to an alias. I also don’t get an error message from the received mail account (Gmail and Hotmail in my case). So it doesn’t seem to be bounced back to the sender.

Whenever I tail -f /var/log/mail.log, nothing is visible, only POP3 and IMAP sync records and log-in attempts from multiple unknown IP’s. Nothing about a received e-mail what so ever. It’s also not visible in the Roundcube webmail. Commands mailq and postqueue says the queues are empty.

The /var/log/mail.log does not mention the mail that the MiaB installation received.
I have looked in directory /home/user-data/mail/mailboxes/domain.tld/admin, but the directories cur, new and tmp are empty. Also the modified timestamps for the files and indexes in that directory have not been modified since I sent the e-mail.

I have 4 windows open with the following checks for any logging entries, but nothing shows up:
tail -f /var/log/mail.log
journalctl -xefu postfix
journalctl -xefu dovecot
journalctl -xefu spampd

What can I check to see where the e-mail could possibly be?
Thanks in advance! Your help is appreciated!

The command you might be looking for is cat /var/log/mail.log | grep postfix/smtpd - i.e. all interactions regarding incoming mail are listed there.

Are status checks giving any sign of alarm? You can check those in the admin panel.

My theory is:

  • Incoming connections to port 25 are blocked
    • This is different than the usual “port 25 is blocked” issues that we’ve been getting - these are related to sending mail. Yours is about receiving mail - this probably means you forgot to open that port in your hosting provider’s firewall, or something similar.
1 Like

That seemed to be the trick, thanks!
I didn’t think I needed to enable port 25 (just like SSH which I didn’t open for the whole world). Because I sent mails using SMTP port 465. Apparently 25 needed to be available, now it works like a charm. Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.