No custom DNS will propagate

I’m trying to setup a couple of custom dns.

  • root and www (its a Netlify app)
  • a podcast

but after adding the CNAME entries it won’t show up. Even checking whois is only showing the default entries and no sign of my new updated entries.

Email and everything else is working fine.

Any help with that?

DNS entries can take quite some time to propagate (can be several hours). If you want to see what your DNS server is saying, try something like this:

dig @your-server-ip any

Just substitute in server’s your actual IP address (after the @) and you’ll be querying the actual font-of-all-knowledge, your own DNS server. The “any” should return all your DNS entries (there are many). (Whois and most web services will be returning cached (old) results.)

Morning @vheid,

Welcome to MIAB! Would provide a bit more info around your setup?
What OS version and MIAB version you are on?
How did you setup your domain ( glue record ) and where is hosted i.e. MIAB as NS or the domain registrar’s DNS ( custom setup )?
Is this new setup or existing MIAB? Is this the primary MIAB domain or secondary one?
Do you get any error message when you are adding www and CNAME?

I do have some secondary domains that I’m hosting only the DNS & mail for them and web and root are hosted elswere, this works no issues there.


Its Ubuntu 18.04 provisioned by Hetzner - fresh installation. Latest MIAB (56 - got another update yesterday through the dashboard)

I use Namecheap, so have set the glue records through there. The first setup went ok and the email plus the new records were working straight away - but changing / setting new records never had any effect. Never got any error. I thought it would be mostly because of the default TTL of 24h, but adding new records to the installation (other than root/www) didn’t seem to have worked either. They were all CNAME entires, if that makes any difference.

For the time being, I created a new DNS via Hetzner (as Namecheap didn’t have all the record types I needed for some of the MIAB configs). With that I managed to import the file zone file provided by MIAB. This seems to have worked.

But I’d like to try setting up using the MIAB DNS as the primary nameserver.

Good morning, and thanks for the reply

Why? Hetzner DNS is much more reliable.
Ok, ok … it doesn’t matter why but if you do, please set up Secondary DNS somewhere so that your MiaB isn’t a single point of failure.

Now one thing I noticed is that you mentioned setting up ONLY CNAME records. You also mentioned the root of the domain.

You cannot use a CNAME for a domain root. If you did, that explains why it did not work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.