Nginx configs are overwritten automatically


it seems that nginx/conf/local.conf are overwritten by Miab.

I have a specific subdomain with a specific reverse proxy config.

Any way to stop overriding? or how to include my configs in the generated one

@JoshData do you have any answer, please?

Thank you very much.

Unfortunately I don’t have time to answer questions about how to work around Mail-in-a-Box. As a last resort, you can always look at the source code and modify it for whatever you need.

Possibly you could add a file in the /etc/nginx/conf directory with your specific site configuration. That file will not be touched by mail-in-a-box. I say possibly because I’m no expert in nginx configuration and don’t know what that file should look like.

the current solution I found is similar to what you propose by including another config file in nginx.conf before including miab configs

add /etc/nginx/nginx.conf

http {
        include /etc/nginx/mysites/*.conf;


1 Like

nginx is setup with /etc/nginx/sites-available and /etc/nginx/sites-enabled with the expectation that you would add any site configuration to sites-available and then create a symbolic link pointing to it in sites-enabled.
As far as I can tell miab does not mess with this setup. Any page you setup will work, with one exception: The domain you used while setting up will for some reason be covered on top level by miab. So, no www.mydomain.tld or mydomain.tld for us. Which is a bit weird :confused: