Nextcloud large upload fails


I have two Home Assistant instances one quite smal, the other more complex.
Both backup every night with help of this plugin: hassio-nextcloud-backup
The smaller one works fine, uploading the backup (about 140MB) every night, but the larger instance has a backup around 1400 MB but it fails to upload with this error:

Fail to upload snapshot to nextcloud (HTTPError: Response code 413 (Request Entity Too Large)) !

I think it has something to do with the configuration of Nextcloud with MIAB, but I can’t figure out what.

Any idea’s how to solve this?

You probably have to increase the maximum upload size. I have no ready answer for you, but this page looks like a good place to start reading.
Be aware that changes like these fall under the Unsupported Modifications category so basically you’re on your own. Also these changes will probably be reset on an upgrade or new installation of Mail-in-a-box.

I can imagine needing to change a value in a configuration file, but which file? I can’t find the files mentioned in the manual or in topics about similar issues.

First thing you can try

  • look at file /etc/nginx/conf.d/local.conf
  • look for section location ~ ^(/cloud)((?:/ocs)?/[^/]+\.php)(/.*)?$ { should be around line 177
  • there is already a variable client_max_body_size 1G; set
  • change it to 2G
  • restart nginx sudo systemctl restart nginx

Then retry.
If this works you have found the right configuration. However, mailinabox will regularly update the local.conf configuration file, removing the new setting. I don’t have an easy way to fix that.