New mailinabox installation not updating DNS

Hi I’m trying to set up mailinabox for the first time. I did an install on digitalocean first, before setting up glue records and nameservers just to check it out. I then went back and made the proper glue and nameserver settings at

After waiting a while I see the proper dns has propagated when I check other systems and also at however I continue to get glue record and domain resolving errors on the status check. When I do “host -t ns” I see that the box still has the old nameservers, but when doing it on other systems the nameserver is correct. It seems that the box is refusing to update its DNS data. Is there anything I can do to force this?

Did I screw up by installing mailinabox first before making the changes at the registrar? Should I just start over with a new VPS droplet? I did also see a discussion with a similar problem which required disabling DNSSEC which I went back and did after originally enabling it, but still no luck. Also tried rebooting several times.

Thanks for your help.


when I do
$ host
Host not found: 3(NXDOMAIN)

$ host
$ host (my box ip address)
I get output displaying my correct ip address for

This is the content of my resolv.conf which points to digitalocean entries. Seems like this might be the problem? How do I correct?

If you just installed within the last 48 hours, the registrar will take on average 48 hours to update the nameservers for your domain(s) to point to your new mailinabox installation.

Just be patient, DNS is slow it will take time.

If you are only having this DNS issue locally (on your network/computer as an example) run:

ipconfig /flushdns to flush stale DNS records and reboot.

Thanks, I appreciate your reply. Looks like it just updated. I had assumed that everything should have been already updated based on the results at

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.