New install error running initial script

fresh install of ubuntu 14.04 only ran updates and updated to latest security.

when I run the “Curl -s | sudo bash” command I get the following errors.

fatal: Not a git repository (or any of the parent directories): .git
bash: line 42: [: v0.23a: unary operator expected
bash: line 53: setup/ No such file or directory

I have googled this and searched the forums but cant find any clear issues as to what might be wrong. any assistance would be great! thanks

As per my notes the way to install the latest ‘official’ stable version is:

apt-get update && apt-get upgrade -y
curl -s | sudo bash

Please, try if that helps.

1 Like

apt-get is not wanting to work correctly now, just trouble shooting a locked file issue.

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

tho I ran this command before but I will post once I get it to run again.

when I run

apt-get update && apt-get upgrade -y

i get lock file issues but when I run them separate everything works fine.
apt-get update
apt-get upgrade -y

and there is nothing to update and I get the same error on install

can close the issue.

I had already created a folder called mailinabox inside my home dir to run from.

after reading the script and seeing that you do it in the script I deleted the folder and than ran the script and it worked correctly.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.