New install and I am getting errors

The is the first error.

Installing nsd (DNS server)…
Generating DNSSEC signing keys…
Installing Postfix (SMTP server)…
mv: cannot stat ‘/var/lib/postgrey/*’: No such file or directory
Installing Dovecot (IMAP server)…
Creating new user database: /home/user-data/mail/users.sqlite

it keeps going till this >>

Installing Z-Push (Exchange/ActiveSync server)…
Installing Mail-in-a-Box system management daemon…
Installing Munin (system monitoring)…
Command ‘[’/usr/sbin/service’, ‘nsd’, ‘restart’]’ returned non-zero exit status 1.web updated

It then ask for a password and then it as soon as I put in the password and confirm it, I get this.

<!doctype html>

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

If I run the installation again it will finish, but I have to manually add my email address as the administrator and the DNS server will not be running

Public DNS (nsd4) is not running (port 53)

I have rebuilt the server several times and started over, always the same error.

I am on racknerd 2.5 GB KVM VPS

any help would be appreciated.

There might be an issue with ipv6. I’d investigate the ipv6 situation of your vps and try enabling/disabling it depending on your situation. Is there an ipv6 address assigned to the vps?

I had to migrate to a new sever that had IPV6, after that, then everything worked great.