New box: Public DNS (nsd4) is not running (port 53)

Hi there!

I am installing a new server and want to migrate my old one to it. Somehow I am stuck on the following issue: Public DNS (nsd4) is not running (port 53).

Public DNS (nsd4) is not running (port 53) is the notification on the the status page, I already re-ran setup, and rebooted the box a few times. Have been trying several things mentioned on the forum but no luck so far
All other checks on the status page are green
( except dns zones but that’s expected because I am preparing a migration)

bind9 is running, bound to, systemctl-resolver is running too. Can’t discover any differences in my config files compared to my old mail-in-a-box server .

What would you try next?

looking at my log files again it looks like it has to do with IPv6 being disabled on my box - (not sure why)

[2019-05-25 16:57:20.553] nsd[10961]: notice: nsd starting (NSD 4.1.17)
[2019-05-25 16:57:20.556] nsd[10961]: error: can't bind tcp socket: Cannot assign requested address
[2019-05-25 16:57:20.556] nsd[10961]: error: cannot open control interface **::1** 8952
[2019-05-25 16:57:20.556] nsd[10961]: error: could not open remote control port
[2019-05-25 16:57:20.557] nsd[10961]: error: could not perform remote control setup

Did a clean install of the server, and still no IPv6. So it appears something in the setup of my hostingprovider.

Enabled IP 6 manually using the following command
So my issue has been solved