Networking Snag

Hi Guys,

Hoping you can help me shed some light on this.

So every time my box reboots, I need to enter the following commands;

sysctl -w net.ipv6.conf.all.disable_ipv6=0
and
sysctl -w net.ipv6.conf.default.disable_ipv6=0
then
service nsd start

If possible, could someone please shed some light as to why this is the case and what I can do to prevent this from needing to be done, every restart.

Cheers.

Is IPv6 available to your VPS? It is properly configured?

Who is your VPS provider?

I dont use a cloud-hosting solution. I have my own ESXi environment that I use at home.

As far as I am aware, IPV6 is enabled at all levels of the network.

Sorry but we can only support installations following the install guide - i.e. on a VPS located in a data center. So the answer to your question is to reinstall as per the guide.

1 Like

So with this being said, where about in the terms and conditions of use does it state that support will only be provided if a VPS is used? I’m just curious at this stage because if this is the case, MiaB wont be a solution I would be able to use going forward. This is a massive shame because I am a big fan of the project.

There are no terms and conditions that I can find. Just a copyright license (cc 1.0).

MiaB makes assumptions about the environment it is installed to based largely on installing in a VPS hosting environment. So the supported/unsupported is not based on some policy but rather the assumptions built into the project.

If you want to use a different environment, it will be up to you to properly configure that environment.

You may find some help for some things on this forum, but you would most likely have better results posting to a forum for managing environments.

1 Like

No that makes complete sense and many thanks for clarifying that for me!

In all fairness, the issue isn’t a major one, I can live with it but I was hoping that someone may be able to point me in the right direction as I wasn’t sure if it was box related or network related. Many thanks for the information however, it is greatly appreciated!

in /etc/sysctl.conf, you can set these settings. As far as I know, this file is not overwritten by MiaB. These settings should be set after a reboot.

2 Likes

That is absolutley perfect. Added the above to where you said, updated the box, rebooted and BOOM! no need for me to manually run the three commands. I shall see if it holds post next major MiaB release.

1 Like