Namecheap gluerecords error

Hello, everybody. I have the following issue with my miab:

I just do not know why, friday morning my laptop just changed the local ip, switching from 192.168.1.100 to 192.168.1.86. After I realised that (it took me a while, jeje) I remapped the ports needed on my router.

Yet I still cannot receive mail.

Just checked with the namecheap support team, they told me that on their part, the nameservers everything is ok, pointing out to my public IP, and I should do something on my part (which I do not know how to do it. their answer: The additional step you need to perform is to go to your hosting side, the side - Pastebin.com)

So, I also did some cheks using the commands from this thread: Nameserver gluerecords namecheap
(dig @8.8.8.8 ns danpacu.com

; <<>> DiG 9.11.3-1ubuntu1.16-Ubuntu <<>> @8.8.8.8 ns mydomain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45795
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;mydomain.com.			IN	NS

;; Query time: 1049 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sun Dec 19 11:53:30 CET 2021
;; MSG SIZE  rcvd: 40).  

Also, the nmap -F 192.168.1.96 throws me this: (22/tcp open ssh

25/tcp  open  smtp
53/tcp  open  domain
80/tcp  open  http
139/tcp open  netbios-ssn
443/tcp open  https
445/tcp open  microsoft-ds
465/tcp open  smtps
587/tcp open  submission
993/tcp open  imaps
995/tcp open  pop3s). 

So, please, could anyone help me understand what is wrong with my miab instance, and how could I fix it? Should I open any port with udp protocole or not? I feel so lost…

Please, could you help me out?

I can send mail, but I cannot receive. I don’t know what am I missing here…

By th way, I set a static ip using the netplan command. So, locally, it should never change from 192.168.1.86.

Thanks in advance, and please, excuse the long explanation…

This appears to be a local networking issue.

MiaB assumes a networking environment most commonly found with a hosted VPS. You will need to meet these requirements for MiaB to function properly or make the customizations necessary to support other configurations, in which case you are generally on your own unless someone familiar with your customizations comes along to assist you.

Thanks for the interes.
I am not that able tu customize much… I just installed miab, it worked fine untill the sudden change of local ip (which I still don’t know why it happened). Did not do any other changes to the system, due tu lack of knowledge and no need. My interest was only to have a functional mail server with miab.
So, again, thanks for the interest. I’ll keep on looking for info then on the web, maybe I’ll get it working somehow.

You reconfigured the local networking functions of the server, so you did more than “just install”.

MiaB assumes being assigned a public IP address, and your current post suggests MiaB is installed on a private network. You will have to figure out how to get it to work with your networking configuration.

Understood. Thanks a lot for your answer. I’ll keep on trying some fix.

Out of curiosity, why would you have remapped the ports on your router instead of just hardcoding what was a working IP address to your laptop?

That being said, you can’t receive mail because, outside of your local network, nothing knows where your domain is. If nothing outside your network knows who you are, you won’t be able to get mail.

Hello, @blinkingline. As an answer to your question: “y would you have remapped the ports on your router instead of just hardcoding what was a working IP address to your laptop”: I remapped the same ports with the new local ip, thinking that doing so I would recover the server. “Hardcoding” I don’t know exactly what you mean, or if I would be able to do something like that.
As for what @openletter told me I understand that by setting the static ip using this guide (Configurar ip estática en Ubuntu Server 18.04 - Aprendiendo a Virtualizar) I messed up the networking or “something” that stops my server from receiving mail. Therefore, due to the fact that I don’t know what did I do wrong, I must try somehow fix it, or format everything and try a fresh reinstall of Miab (maybe I’ll get it working ok again - untill next localip issue - don’t know which would be a solution). As mentioned, I am on my own - wish me luck,though… jejej.

Port 53 requires both UDP and TCP.

You cannot receive mail because your DNS is unreachable. Opening port 53 to UDP may help, but you need to figure out your port mapping issues.

If it was working with 192.168.1.100 why did you not change it back to that local IP address? That may have been simpler at the outset.

This is handled automatically when your DNS is set up by MiaB. There is nothing to do here regarding this specifically.

Well, thanks a lot for your instructions. I assure you, all the answers have helped me a lot. Simply because I feel I am absolutely in the dark, so any light, for as little as it may seem, helps me. I’ll try out the 53/udp.
I did not change the local ip because I didn’t think about doing it. Juste lelft the new 86 one. I really don’t understand why did it change in the first place. And it took about several hours to figure out checking the ip… so imagine poor knowledge I have.
I’ll keep you informed @alento (and everyone else too, of course).

It was definitely the 53/udp port. Now everything is ok, no error. Just performed a dig ns mydomain.com and got the “status: NOERROR”. It’s simply fantastic. Thanks for the hint, @alento. I’m in debt with you - really. Thanks a lot!!!
THe good thing is above anything else what I learned: the 53 port, /udp also, the checking commands (even though I am still in the copy/paste fase), and also I don’t have to format and reinstall everything!!! This is a big win for me… thanking you all for it!

1 Like

I am only speculating here … but in general most home routers act in this manner …

When a new device is attached an IP address is assigned by DHCP. Typically the router looks to see if there is an IP address that the devices MAC address connected to previously and connects to it.
If your device (laptop) is not connected and another device connects that other device may be given the IP address used before by the laptop, so when the laptop connects again the original IP may be in use by another device.

My guess is that something like this is what happened to you.

Most routers have a mechanism to reserve a specific IP address for use by a specific device. I suggest that you explore this in your router’s settings as by changing the laptop’s IP assignment to static, you are likely to lose the new IP (.86) and be in the same position. So you want to set the ‘static IP’ in the router instead … hope this helps some to avoid a similar issue in the future … but it won’t help fix things today.

" but it won’t help fix things " - you are wright about it.
But thanks to your explanation I get to understand a bit more how things work around.
I will begin the “exploration” of my routers and will give it a try - hopefully I will get it going ok, using your explanation as a “guide”.
So, thanks again.
I just checked if I received any mail and yes, it came back to life my miab instance, so I’m good with this by now (and crossing fingers to keep it like that).
And by the way, Happy Holidays to you all!!! Have a great time.

1 Like