redirects to - How to change it?


Hi there,
I’ve installed Mail-in-a-box recently, and all is going well, even if I’m not really an expert in this kind of things :smile:
I’ve set up my VPS (Linode) Host name as
My only problem is this:
when I type in the browser (I’ve registered a .it domain, that’s why) it redirects to , showing the “mail-in-a-box” page with le link to the mail, as it probably supposed to be, I think.
I need to redirect the to my website,, hosted on another VPS server.
Is it safe to do ? Do I have to do that form mail-in-a-box control panel or from my Domain register (Godaddy) control panel?
I know it’s a silly question for you expert guys, but it took me ages to get it working and don’t really want to mess it up :smile: doing something wrong.
Hope you can understand it. I’ve tried to search before posting here, but didn’t find anything really.
Also, Is it possible to customise the “mail-in-a-box” Homepage ( with a personal page with logo and email link ?
I really hope someone will be kind enough to reply…
Thank you very much guy.
Great job !!! I really appreciate it.



I need to redirect the to my website,, hosted on another VPS server.

Just to clarify, you want to do a redirect to a different domain name (not just showing your website at There isn’t a good method to do that now. (It’s possible but tricky.)

If you want your website to show up at, you can do that by using the Custom DNS page of the /admin control panel to set a custom A record for the domain to be the IP address of your other server.

Is it possible to customise the “mail-in-a-box” Homepage ( with a personal page with logo and email link ?

Yes. See the “Web” page inside the /admin control panel.


Hi Josh,
Hss been a while from your last reply, I know…
I tried to solve it in the meantime, but we no luck :frowning:
To clarify:
I have my box hosted on (so subdomain is actually
I want the (w) redirect to (w) on a different IP (that hosts my website)
It’s vital for me being able to redirect it, since I have few chances that my clients will try to access my website using (used for my email address) , when the website is actually hosted on

  • I tried everything. I tried to use the Custom DNS pointing my to different IP (same IP of website)
    Didn’t work. always redirect to -
  • I tried to set a CNAME, to redirect to . No luck. Still redirect to
  • I tried to add an alias . Still the same, no luck. I’ve also tried to add a Domain Alias for, but still nothing.
  • then I tried in Godaddy, changing the Host @ value of my pointing to the different IP. But Nothing.
  • Tried with CNAME in Godaddy, with the same result. I even tried to redirect the domain from godaddy to the other domain, but when it type (w) it still redirecting to

Basically, whatever i change, or whatever i try, it will always point to
I made sure that CNAME www pointing @ was set in Godaddy.

I don’t have any problem with the box. Emails working fine.
But cannot really redirect my that host my box to
I have many other domains that redirect (through Godaddy redirecting option) my website domain.
I also tried to wait few hours between changes, even couple of days sometimes…thinking that propagation could be the problem, but not, it wasn’t :frowning:
The website domain ( is on Cloudflare, if that matters…don’t know if it can create any problem.
I’m desperate, there must be something I’m missing or that I’m doing wrong, but cannot figure it out.
If i cannot redirect the domain hosting my box to my website domain, then i will have to give up :frowning: and i don’t want that. I’m really enjoying managing my own email server.
Thanks in advance for your help.


Where is your DNS actually hosted, on your box or at Godaddy?

Any of the things you tried could/should have worked. Did you wait for DNS to propagate - meaning, old results can be cached at various locations for about an hour?


DNS for are hosted on the box itself…
I tried to wait a couple of hours at least eveytime. sometimes even a couple of days.
To be honest, if i remember correctly, sometimes I had the impressions that it would start to work after certain changes, but then, after few hours, came back as it was, pointing again to
I’m pretty sure i’ve got it working once, without www . Using www, it opens the HTTPS error certificate page and then again to

In theory, I thought that not changing anything in Godaddy and just use a CNAME from the Box DNS Panel to redirect to should have worked… but not…
What do you think? does it worth to tried again, setting Godaddy with box IP and just set a CNAME in the BOX Panel (using the . (dot) at the end of the destination domain, i know it’s important) and try to wait another day for propagation ??? maybe i have to wait longer, don’t know…

Also, something that is not clear: would you set 2 CNAME in the DNS panel ? one for my and one for (putting the www in the subdomain field in the Custom DNS Panel)… OR do you thing that the CNAME in Godaddy (www pointing @) should be enough ???

Now I’m also starting to think that maybe Cloudflare could be the problem because it’s using different DNS that mess up with the CNAME setting… but I setup cloudflare just for the website domain, so it shouldn’t really affect what i’m trying to do. Since I just want to redirect the domain that hosts my Box, to another domain that use cloud flare DNS, that’s it. I did it from Godaddy panel for other 5-6 domains an it just works fine…
It looks like there’s something in the box that overwrite any other setting i try to change. even from Godaddy.
don’t know actually… i’m trying anything.
Let me know what you would try to change and I’ll try it, waiting at least a day this time, before change setting again. Just to make sure it propagates.
Thanks for your help Josh !!!


Make the change and then let me know, and I will see if I can see what the problem is by looking at the DNS.


well, I’ve just noticed that in the Godaddy Control Panel , it looks like I’m using the Premium Godaddy NameServers, because when i try to set CUSTOM ones I’m not allowed to set the same IP address for both NS1 and NS2 nameservers (maybe because the .IT domain I’m using).
I’ve set 2 A record (still in Godaddy) for NS1.BOX and for NS2.BOX using the box IP (same IP for both nameservers) , and I’ve also set 2 NS Records, NS1 pointing to and the other one is NS2 pointing to
In this way, even if Godaddy says that I’m using it’s own Premium Nameservers (i actually paid for them), when i check the System Status Check from the Mail Server i get: "Nameserver glue records are correct at registrar. [ns1/ ↦ correct IP address] for both my and
Does it looks weird ? or it’s all fine ? I’ve never noticed that before.


I just made the changes, setting the box’s IP in Godaddy, and having just a Cname for www @ in its setting.
Then I went to the Custom DNS Panel, and set 2 CNAME forwarding (one for and another for
Now i’ll try to wait for a while.


Ugh no this is too complicated! If you’re using Godaddy for DNS, don’t use the box for DNS at all — and ignore the glue records status check because you’re not using the glue records the box wants anyway. I can’t really help when your DNS is so complicated.


Ok, I understand it. No worries :frowning:
What i don’t actually understand is:
What ‘s the downside of NOT using the DNS from the box and using external DNS (Godaddy of Cloudflare DNS) ??
If it’s like you say, i’ve never used the DNS the box wants me to use from the very beginning, but i never had problem with my delivery emails… and I’ ve been using it for more then 6 months now…


The downside is the box doesn’t set it all up for you (MX, SPF, DKIM, DMARC, DNSSEC, etc.), you have to do it yourself.


Just to let you know that I managed to get it working :smile:
I moved my DNS from Godaddy through Cloudflare (adding my to Cloudflare), and I manually re-configured everything in there.
Now, using the more advanced redirecting functions available in Cloudflare, i’ve been able tor redirect my domains as i want. Just had to wait few hours to get it propagated.
At the end, the buggy Godaddy control Panel was my problem (doesn’t work well with .it domains).
Now everything seems fine (fingers crossed) and i can also take advantage of the advanced cache functions available in Cloudflare.
Thanks for your help.


Hey, thanks for asking here. I need to have the same setup as yours, GoDaddy + Cloudflare. Already uploaded the default DNS Records to Cloudflare from GoDaddy. How do I set up my records like yours? I also have a default webpage in that domain setup like you. I’d appreciate it if you could provide me some more details as to how you’ve achieved this. Thanks.


I was having the same trouble,
at Godaddy control panel I set A record to the with the actual IP host
and it was redirecting to the
Until I opened with a different browser, I was able to see my actual website without redirecting to
So don’t forget browsers cache :slight_smile: or what is called