My SMTP Details are not working


#1

Hi Everyone,

Please help! My SMTP Details are not working. All ports (25, 465 and 587) are opened, yet it’s not sending. And this is mainly what I need Mail ina box for. Please, help. Thanks


#2

Hi,

Unfortunately a lot more detail will be required. Exactly what is not working? Your client cannot send, connect, authenticate? If you could explain in greater detail that would be helpful.


#3

It’s can’t even connect at all. For you to understand better, sign up for a free trial account at www.gigomail.com. Create a sending server and put in your Mail In a Box SMTP Details as your sending server. Then, try to send a mail to see.
I have done all I could, tried different ports and authentication methods, all to no avail. Please help in whatever way you can. Thanks


#4

MiaB does not relay mail. I am honestly not interested in signing up for that service, so I cannot help you there … but at a quick glance it seems to me that you need to be using their G-Self (Use Your Own SMTP) plan.

I tried to view one of their video’s but absolutely could not understand the dialog.

Maybe you could attach screen shots showing the input required and error messages (if any).

If you’d like to create an account on your MiaB for me, I’d be happy to test SMTP to see what is not working. PM me the details if so.


#5

Here are the screenshots of the SMTP Details I used and the errors I get:

SMTP Details Screenshot: https://prnt.sc/mfykmg

SMTP Errors Screenshot: https://prnt.sc/mfyle4

Meanwhile, I created an account for you in my MiaB. How can I inbox you the login details?


#6

To send a private message, click on the my username.

And herein lies the problem! There is an issue on gigomail.com’s side. @murgero may be able to offer more information about the error as he is much more proficient with PHP than I am. My guess is that either they haven’t enabled something required on their server, or there is something in your account that needs to be set.


#7

I have contacted them, and they said the issue is not from their end, because, all other SMTP Providers work well with all sorts of authentications on their system. Besides, they have enabled all PHP Modules that have to do with SMTP Mail Authentications


#8

Well, they are incorrect. Try contacting them again and providing them that screen shot if you hadn’t before. It is clearly an issue on their side. I still need your hostname to check that your SMTP is reachable, but from the error message shown, they are not even attempting to send as there is an error with their set-up.


#9

I have even gone to use the SMTP Details in another platform, yet same error. Still not connecting


#10

I have connected to your server using telnet on port 587 just fine.
I have run a test to determine whether or not starttls is working on your server. It passed with flying colors. https://www.checktls.com/TestReceiver
I am not certain what the issue is other than I feel 100% it is not within your install of MiaB. Unfortunately, I do not know what else to check. I still maintain based upon the image of the error that it is a PHP issue with the service you are working with. However, I am not a PHP expert so I cannot say that with 100% certainty. There are a couple of other regular contributors to this forum who have more experience than I do with PHP. I hope that one of them sees this and offers their advice.


#11

I need the output of this from SSH or console:

php -i | grep -i openssl


#12

Here’s it:

SSL Version => OpenSSL/1.0.1f
openssl
OpenSSL support => enabled
OpenSSL Library Version => OpenSSL 1.1.1a 20 Nov 2018
OpenSSL Header Version => OpenSSL 1.1.1 11 Sep 2018
Openssl default config => /usr/lib/ssl/openssl.cnf
openssl.cafile => no value => no value
openssl.capath => no value => no value
Native OpenSSL support => enabled


#13

Well at the very least OpenSSL is working in PHP.


#14

Short answer
Use port 587 and specify the encryption type as TLS

If you want to know more read on.

There’s two possible modes of encryption available.
Implicit, where the client connects to a separate port and negotiates encryption from the outset.

Explicit, where the client starts with an unencrypted connection on the standard port and then upgrades to an encrypted connection via StartTLS.

Some clients in the past (Outlook being one of them) Used the term SSL for Implicit connections and TLS for explicit connections.

I did try signing up for a trial account to test this out, so I can confirm the above solution definitely works.

Bear in mind that you do have to sign up for one of the more expensive plans once the trial is over.

Tim


#15

I didn’t even think to ask if they tested port 587. Good thought! I hope this is the solution, sure sounds like it will work.


#16

I already tried connecting on Port 587 with TLS Encrytion, it didn’t work. It returned "Unknown SMTP Error. See Screenshot:http://prnt.sc/mgicqk

Or is there a service I need to sign up for first? If so, where is the link to the service? I really do not understand what you mean by “I did try signing up for a trial account to test this out….”

Can you just explain more? Thanks


#17

I actually tested this out prior to posting.

Here is what I put in each field:

Name - My Box
Hostname - box.example.com
Username - My FULL email address
Password - Speaks for itself
Port - 587
Encryption Method - TLS < This is case insensitive>

The only thing I would point out is that MIAB expects that the From: address be THE SAME as the email address used to authenticate the send. It’s very picky about that,

Tim


#18

Wow! It worked. Thanks a lot man. You made my day. I was actually using another email as “Send From” instead of the email address used to authenticate the send. Thanks once more. I’m very grateful


#19

EXCEPT if you have an alias setup on the account (done in the alias page in the admin panel)

If you set the FROM address different from AUTH address, make sure FROM is an alias of AUTH.


#20

Thanks for the correction