MIAB install on host using private IP behind hardware firewall 1-to-1 NAT

What /etc/hosts entries are required for server with private IP behind hardware firewall

None - at least nothing more than what the install does, it puts in an entry for the box’s local address.

My box is running behind a firewall with NAT. All I did was ensure the router was passing all required ports to/from the box.

It’s a bit different with IPv6, but get it working with IPv4 first. For IPv6 it’s normal to assign the box multiple addresses, a local one and a global one, then ensure that traffic for the global address can get through the firewall.

I installed it but getting DNS name resolution error on Web console and when I ran the nslookup on box same error

the /etc/hosts file is pointing the mailbox.xxx.com to private IP which is nated on cisco firewall (1 to 1) and all the required ports are opened on firewall

user@mailbox:~$ cat /etc/resolv.conf
user@mailbox:~$ nslookup mailbox.xxxx.com

** server can’t find mailbox.xxxx.com: SERVFAIL

A simple install on a completely clean Ubuntu instance should be all you need. No need to tweak or adjust anything. For your reference, on my (pretty standard MIAB) the /etc/hosts looks like: localhost box

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

and my /etc/resolve.conf is:


It sounds like you’ve changed things that didn’t need to be changed, and confused the situation. I would be inclined to start again from a fresh Ubuntu 18.04. Assuming that your fresh Ubuntu can see the rest of the world (eg. ping, nslookup and wget work) then the MIAB install should be all you need. (You’ll need to confirm that all the required ports are open through your firewall, but that does not involve any changes to your MIAB box.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.