Messages are not getting in


I have setup Maib for my client. He complains that he doesn’t get messages from other people sometimes. I checked that in Roundcube of his account, spam folder wasn’t mapped to spam. Could this be the issue?

Is there a possibility to force all messages marked as spam to forward them into user’s inbox?

First step is to verify if the box is receiving the mail. Check /var/log/mail.log for this

In the logfile you can see - if the mail is received - if it’s ‘purged’ by the spam stuff, although this is not likely.

If you map the Spam folder in RoundCube to Spam, (i don’t know how, because i don’t use round cube), you should see messages in that folder if it’s filtered by the MIAB spam filter.

Yep, mailbox works fine. It receives e-mails, however not all. And I can’t see in logs any failed attempts or something similar. It feels like messages don’t reach the servers. That could be the issue on sender side, but I need to make sure that there’s no issue on my client’s side.

Regarding roundcube, this setting looks like:

and it was set to “—” when I checked client’s mailbox. I’ve set it to “Spam”. So I just guess that when “—” was set it discarded spam messages.

If you don’t see it in the logs, it’s not on your server side, but somewhere else. Also failed attempts should be logged.

A common issue is that a domain is moved (or the MX pointer is moved) to a new server and the leaving party still has mail configured for this domain.

So, a domain is receiving all the mail, except from the leaving provider.

Good luck.

One maybe-too-obvious cause might be that the user also uses a mobile email reader. In that case, any emails marked as “read” in the mobile email client are deleted from the server before being delivered to the desktop client.

You may want to double check with the service provider hosting your server, or the ISP providing you service that the proper ports are open. If they are not, this may be the very cause of your problem. I had sporadic functionality with my install before requesting and validating this with my provider, since then the install has functioned without concern.
Also, make sure that the ISP that holds your domain registration MX records are pointed to your server, and if you are using MIB to server DNS that this is too pointed to your box.
The best part of this, is once you get it fixed you will have not only learned how you can improve it, by messing with the settings but it won’t break again.

Found the issue. It was DNS settings. MAIB suggested to set MX for second domain pointing to first one’s mail A record (I had to set MX on, which didn’t work). Setting up MX for to CNAME which points to the same IP of the mail server solved the issue. So both domains have A ‘mail’ record pointing to mail server, and both have and MX records accordingly.