not valid e-mail address

I have but the setup doesn’t detect .ninja as a valid domain, i am using latest git.

Hello. There isn’t anywhere a list of TLDs that .ninja isn’t on. But can you tell me exactly where you’re running into the problem? The latest on git switched email address validation to a new library I put together, so there may be some bugs.

It’s on the beginning, “What email address are you setting this box up to manage?”, i entered, then it will loop at “Your Email Address” - That’s not a valid email address.

You may be getting caught by the strict rules for permitted characters in user account names: letters (a-z), numbers, dashes, hyphens, periods, and the @ sign are the only permitted characters in the address.

If that doesn’t solve it, could you post the actual domain you’re using (or PM me if you prefer)?

Okay I got your PM. I don’t see any reason why it wouldn’t work at that stage. (Maybe you typed a space at the beginning or end or had some non-obvious Unicode characters somewhere in it?)

There’s a new check to guard against accidental misconfiguration that would allow domain control validation hijacking. admin@ can no longer be used for mail accounts — only aliases to administrative accounts. This isn’t checked at the start of the setup, but it is checked at the end. If the error actually showed up at the end of setup, that might be this. I’m committing a change to allow the first account to skip this check:

Can you let me know if this might have been the problem?

Tried the latest git, still error That’s not a valid email address. now i can see the following traceback :
Traceback (most recent call last):
File “management/”, line 5, in
from email_validator import validate_email as validate_email_, EmailNotValidError
ImportError: No module named ‘email_validator’

Tried non admin address as also producing the same error.

Already make sure there is non-standard character at the beginning or ends still causing this error.

Ergh. Yeah. Okay. I totally messed up new installs. Thanks. I just committed a fix (I hope). Let me know?

Seems fix it!, thanks a lot :).

Thanks for letting me know!

This bug seems to be back again in the latest version. I’m stuck at the “What email address are you setting this box up to manage?” stage as it won’t accept any email address that ends in “.domains”. I have another mail-in-a-box instance running version 0.23a which is using a “.domains” domain name without any issue.

#MeToo :slight_smile: I have same issue.