Mailchimp not picking up CNAME - how to verify my setup?

I use to send out mails from one of my domains. In order to get them verified, I followed their setup page which says that I need to add the following:

DKIM: Create a CNAME record for with this value:
SPF: Create a TXT record for with:
v=spf1 ?all

I did that yesterday morning but mailchimp still complains about the dkim cname record isn’t there. How can I verify that it is actually there?

You could use this web tool to test DKIM:

Did the test for you with:

  • selector: k1
  • Domaine name:

but returns _DKIM Record for a wrong value as v=spf1 -all when by default looks for a p=… response.

Hope this helps.

1 Like

That is strange. I have added the txt exactly as they describe. Could it be an error on the mailchimp page?

It’s not asking for a TXT record for DKIM… It’s asking you for a CNAME record for DKIM and a TXT record for the SPF one

To check the spf you could use this test, too:

v=spf1 **?**all value is returned a valid there but you may try a v=spf1 **~**all one if still with problems.

yes that is what I added TXT and CNAME like described in the text mentioned in my initial post.

I tried changing the TXT from ? to ~ as proposed. same result

The test has no reason to lie… please, double check you haven’t a double entry for the k1 selector (perhaps one as a CNAME and may be other one as TXT):

About changes note that may need up to 48h to propagate worldwide (mainly if you are mirroring your DNS records to a secundary (slave) DNS server)

what you see in the screendump is what I have. The only thing I can think of is that the *.domain could give some problems. But normally that isnt the case

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.