Mai-in -a-box l iInsatll error in v0.28-10-g6eb9055


#1

Hi I have installed mail in a box on ubuntu 14.04. Here is my last log but GUI doesn’t appear . what can I do?

Okay. I’m about to set up me@mail.naz.tech for you. This account will also
have access to the box’s control panel.
password:
(again):
mail user added
updated DNS: OpenDKIM configuration


Mail-in-a-Box uses Let’s Encrypt to provision free SSL/TLS certificates
to enable HTTPS connections to your box. We’re automatically
agreeing you to their subscriber agreement. See https://letsencrypt.org.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Registering without email!

IMPORTANT NOTES:

  • Your account credentials have been saved in your Certbot
    configuration directory at /home/user-data/ssl/lets_encrypt. You
    should make a secure backup of this folder now. This configuration
    directory will also contain certificates and private keys obtained
    by Certbot so making regular backups of this folder is ideal.

Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

https://XXX.XXX.XXX.XXX/admin

You will be alerted that the website has an invalid certificate. Check that
the certificate fingerprint matches:

18:95:F0:9C:1A:34:9A:52:F8:0D:5C:38:73:86:DB:AC:83:E2:B0:FA:E0:C9:49:9B:99:A0:18:E9:47:5D:80:77

Then you can confirm the security exception and continue.


#2

What exactly are you trying to do having Cloudflare manage your DNS?

You do not seem to have a MX record set up. Your port 25 also seems to be blocked.


#3

I am trying to again setup but facing this error. Waht is the reason? :frowning:

Please read the Terms of Service at

https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must

agree in order to register with the ACME server at

https://acme-v02.api.letsencrypt.org/directory


(A)gree/©ancel: (A)gree/©ancel: An unexpected error occurred:

Traceback (most recent call last):

File "/usr/bin/certbot", line 11, in <module>

load_entry_point(‘certbot==0.26.1’, ‘console_scripts’, ‘certbot’)()

File "/usr/lib/python3/dist-packages/certbot/main.py", line 1364, in main

return config.func(config, plugins)

File "/usr/lib/python3/dist-packages/certbot/main.py", line 721, in register

_determine_account(config)

File "/usr/lib/python3/dist-packages/certbot/main.py", line 520, in _determine_account

config, account_storage, tos_cb=_tos_cb)

File "/usr/lib/python3/dist-packages/certbot/client.py", line 182, in register

regr = perform_registration(acme, config, tos_cb)

File "/usr/lib/python3/dist-packages/certbot/client.py", line 207, in perform_registration

tos_cb)

File "/usr/lib/python3/dist-packages/acme/client.py", line 777, in new_account_and_tos

_assess_tos(self.client.directory.meta.terms_of_service)

File "/usr/lib/python3/dist-packages/acme/client.py", line 768, in _assess_tos

check_tos_cb(tos)

File "/usr/lib/python3/dist-packages/certbot/main.py", line 498, in _tos_cb

cli_flag="–agree-tos", force_interactive=True)

File "/usr/lib/python3/dist-packages/certbot/display/util.py", line 223, in yesno

no=_parens_around_char(no_label)))

File "/usr/lib/python3/dist-packages/certbot/display/util.py", line 90, in input_with_timeout

raise EOFError

EOFError

Please see the logfiles in /var/log/letsencrypt for more details.


Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

https://XXX.XXX.XXX.XXX/admin

You will be alerted that the website has an invalid certificate. Check that

the certificate fingerprint matches:

27:DB:63:53:2E:0F:39:DC:CC:BD:8C:8F:0D:F8:8A:C0:BE:AE:79:9B:CB:2E:BE:27:41:6E:96:E6:20:5E:7F:1D


#4

The cause of this error is that the install script isn’t properly pausing to allow you to accept the Let’s Encrypt ToS.

The fix is to rerun
sudo mailinabox from the command line.

But this has nothing to do with your DNS problems. What steps have you taken to solve them?


#5

But I was trying with root user.


#6

Then you don’t need to use sudo … what about the other issues?


#7

I have installed it another way. But my system check status showed

System
:heavy_multiplication_x: Public DNS (nsd4) is not running (port 53).
:heavy_multiplication_x: Incoming Mail (SMTP/postfix) is running but is not publicly accessible at XXX.XXX.XXX.XXX:25
:heavy_multiplication_x: Outgoing Mail (SMTP 587/postfix) is running but is not publicly accessible at XXX.XXX.XXX.XXX:587
:heavy_multiplication_x: IMAPS (dovecot) is running but is not publicly accessible at XXX.XXX.XXX.XXX:993.
:heavy_multiplication_x: Mail Filters (Sieve/dovecot) is running but is not publicly accessible at XXX.XXX.XXX.XXX:4190.
:heavy_multiplication_x: HTTPS Web (nginx) is running but is not publicly accessible at XXX.XXX.XXX.XXX:443.

show more|
|✖|The SSH server on this machine permits password-based login. A more secure way to log in is using a public key. Add your SSH public key to $HOME/.ssh/authorized_keys, check that you can log in without a password, set the option ‘PasswordAuthentication no’ in /etc/ssh/sshd_config, and then restart the openssh via ‘sudo service ssh restart’.|
|✖|There are 2 software packages that can be updated.|

But my firewall status

root@testmail:~# ufw status
Status: active

To Action From


22 ALLOW Anywhere
53 ALLOW Anywhere
25/tcp ALLOW Anywhere
587 ALLOW Anywhere
993 ALLOW Anywhere
995 ALLOW Anywhere
4190/tcp ALLOW Anywhere
80 ALLOW Anywhere
443 ALLOW Anywhere
22 (v6) ALLOW Anywhere (v6)
53 (v6) ALLOW Anywhere (v6)
25/tcp (v6) ALLOW Anywhere (v6)
587 (v6) ALLOW Anywhere (v6)
993 (v6) ALLOW Anywhere (v6)
995 (v6) ALLOW Anywhere (v6)
4190/tcp (v6) ALLOW Anywhere (v6)
80 (v6) ALLOW Anywhere (v6)
443 (v6) ALLOW Anywhere (v6)

Where is the problem? I am using mikroTik and I have allowed 25,443 port in my NAT rules and I can send receive mail.


#8

The problem is that nobody can possibly help you if you do not offer any answers to questions and if you completely go in another direction in the mean time.
Another problem is that your port 25 is likely blocked by your VPS provider … oh wait, it looks like maybe you are trying to run this on a server at home with a residential connection? Most residential ISP’s block port 25.

Good luck.


#9

I have used VM from my own server not from VPS provider and I have another mail server in this IP block. I have also send and receive mail from mail-in-a-box. But my system shows
:heavy_multiplication_x:
Incoming Mail (SMTP/postfix) is running but is not publicly accessible at :25.

And Network shows
Outbound mail (SMTP port 25) is not blocked.

Why?


#10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.