Login Failed - No authorization header provided

This morning I tried to login and received the above error. Rebooted but still getting the same error :frowning:

Need further info to be able to debug this:

  • browser/OS?
  • browser extensions?
  • miab version?

That’s weird, it’s working now!

Hmmm, very strange, it’s broken again.
I’ve tried it in Chrome and Edge.
MIAB v0.51
If I reboot the server it works again.

Strange. This error is thrown in our auth module when a request does not have an Authorization header.
When logging in via the control panel page, it should always be there. I just looked at the login code again and can’t see an obvious flaw on that end. My best guess is that the header is stripped somewhere along the way, possibly due to a redirect. May I ask where the box is hosted and what kind of network you are on when this happens?

If you don’t mind doing the following, it would help with debugging:

  1. open Google Chrome
  2. go to the admin login page
  3. right-click and select ‘Inspect element’
  4. go to the ‘Network tab’
  5. now try to log in
  6. in the list, there should be an entry with a name me?_={number}
  7. click on it and select the Headers tab
  8. scroll down to Request headers and see if there is an entry that looks like authorization: Basic {random_string}