Linode install troubles

I’ve successfully installed MIAB on DigitalOcean before. I’m now trying it on Linode.

I have my name servers set up the same as I did with DA, but with the correct domain name and Linode IP address for the new server. Dig returns the correct ns1 and ns2 info. So I proceed with the install according to the guide.

In the guide it says: “…you may not be able to set the reverse DNS on Linode until after you have finished the rest of this guide (Linode only accepts reverse DNS changes once the forward DNS is working, which your box will handle by the end of this guide)”

However during the install I see various instances of “unable to resolve host”. That error makes sense because MIAB hasn’t configured forward DNS yet. But then the install stops with this:

Upgrading to Nextcloud version 12.0.5

sudo: unable to resolve host
creating sqlite db
sudo: unable to resolve host
Nextcloud is already latest version
Installing Z-Push (Exchange/ActiveSync server)…
fatal: unable to access ‘’: server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

I’ve tried this process three times now, resetting the DNS stuff at the registrar to defaults and set them again for my Linode IP, and I’ve recreated the Linode. I’ve waited at least 24 hours between each attempt.

I also tried manually adding the reverse DNS in Linode, but it fails because the reverse DNS must have a matching forward entry that points to one of your IPs.

Is the install being stopped because my forward DNS isn’t resolving? I don’t know why this is an issue since it worked fine with DA.

Read this one: Fatal error installing Z-Push


export GIT_SSL_NO_VERIFY=1; curl -s 21 | sudo -E bash

Worked just fine.

1 Like