Linode DNS Manager

On Linode:
a.) Ubuntu 14.04 with Mail in a Box installed.
b.) my subdomains,,,

a.) I registered my domain with Google Domains.
b.) My website,, is on Google Cloud Platform.

Three DNS Managers, oh my!
a.) Linode has a DNS Manager
b.) Mail in a Box has a Custom and External DNS webpage
c.) Google Domains has a DNS manager

I am struggling to configure all three. I am not sure if I even need to configure all three. Any suggestions? Many thanks!

Mail-in-a-Box will be the only DNS server you will need to configure. Just use the guide[0] to point your Google Domain to your Box on Linode and setup rDNS on Linode.


Do you mean…

Google Domains (DNS Manager) “My Linode IP Address” “My Linode IP Address” “My Linode IP Address” “My Linode IP Address”

From Linode:
I think you’re combining steps where you shouldn’t:
Note that it says “If you are using an external DNS provider, e.g. if you already have a website on your domain name, you may skip this section.”
If you’re going to use Linode’s DNS service, then don’t do the nameserver bits - it’s going to make this more complicated for you. If you’re not going to use Linode’s DNS service, then you don’t need to setup anything in the Linode DNS Manager. You’d handle all the DNS records in Google’s control panel.

But Mail in a Box Status Check says
Your box’s reverse DNS is currently (IPv4) and [Not Set] (IPv6), but it should be Your ISP or cloud provider will have instructions on setting up reverse DNS for your box.

And the ISP/Cloud Provider, Linode, seems to require DNS records for reverse DNS
Following Linode - Reverse DNS on
Gives me the following error message:
• No match was found for ‘’. Reverse DNS must have a matching forward entry that points to one of your IPs.

A matching forward entry that points to one of my IPs is, per Linode is
A matching forward entry would come in the form of an A or AAAA record created in the zone file for the domain, pointing towards an IP address, i.e. an A record for pointed towards (where is your real domain name and is your Linode’s IP address).

Per Linode,

Once you have created an A or AAAA record for your Linode’s IP in the Google Domains control panel (and once that change has reached the rest of the internet) you’ll be able to set Reverse DNS in the Linode’s Dashboard under the Remote Access tab.

I am not sure if you have set your glue records and the name server according to the installation guide.
First glue records: -> your IP address -> your IP address

Then the name server configuration (set two name server):

This should be all in your Google Domains interface.

1 Like

Many thanks, pxl!!

After rebuilding the server a few times, it works.

I also made the mistake of have a user account for plus an alias for

I am just waiting for my domain to update but I guess that takes some time, apparently.

Have a great weekend :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.