Issue with Letsencrypt on newly installed 0.61.1 and glued records

I’ve recently migrated to 0.61.1, configured a dedicated domain, everything seems to be running smoothly with the exception of TLS (SSL) certificate for the box domain.
Let’s encrypt log:

"DNS problem: SERVFAIL looking up CAA for - the domain's nameservers may be malfunctioning

I’ve glued and, all system checks are green with the exception of TLS (SSL).

Any pointers? Isn’t the box dns supposed to resolve the letsencrypt challenge?

Thank you. In advance but also for this great product.

I did some further troubleshooting and found the challenge is http based, not DNS.

2023-02-21 17:36:04,693:DEBUG:urllib3.connectionpool: "POST /acme/authz-v3/205283304466 HTTP/1.1" 200 989
2023-02-21 17:36:04,693:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Tue, 21 Feb 2023 15:36:04 GMT
Content-Type: application/json
Content-Length: 989
Connection: keep-alive
Boulder-Requester: 974507376
Cache-Control: public, max-age=0, no-cache
Link: <>;rel="index"
Replay-Nonce: C4004bMFBrI7J3cHWwteUP5_txN8yKYe5S06-xgXBr5aQF8
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800

  "identifier": {
    "type": "dns",
    "value": ""
  "status": "invalid",
  "expires": "2023-02-28T15:35:58Z",
  "challenges": [
      "type": "http-01",
      "status": "invalid",
      "error": {
        "type": "urn:ietf:params:acme:error:dns",
        "detail": "DNS problem: SERVFAIL looking up CAA for - the domain's nameservers may be malfunctioning",
        "status": 400
      "url": "",
      "token": "0PLxwtgueQObsnXnfMUnXX29ZsM2kOo06psHs2ffneQ",
      "validationRecord": [
          "url": "",
          "hostname": "",
          "port": "80",
          "addressesResolved": [
          "addressUsed": ""
      "validated": "2023-02-21T15:35:59Z"

Did further troubleshooting and I think there is nothing wrong with the http challenge, the .well-known/ path works as intended.

After reading this DNS problem: SERVFAIL looking up CAA - #8 by Raquel - Help - Let's Encrypt Community Support
I am back to thinking this is a MIAB dns server issue.

just check check status of bind9 like : service bind9 status and if any errors found restart like : service bind9 restart then provision TLS (SSL).

Thank you for your suggestion.
Tried it, same result.

Are you still on this? If I look at the nameservers of the domain I get the following

Are you hosting DNS on your box? If so, you not only need to create the glue records, but also change the nameservers of the domain at your domain registrar.

I have given up and moved to an external DNS.
No more errors.