ISP without reverse DNS for IPv6


#1

Hello, I have reverse DNS [Not Set] (IPv6) and my ISP says they do not support IPv6 PTR record. This results in mails bouncing from some services, e.g. freenet.de:

host emig.freenet.de[2001:748:100:40::8:118] said:
550-inconsistent or no DNS PTR record for 2a03:xx::1 (see RFC
1912 550 2.1) (in reply to RCPT TO command)

I looked up reverse DNS for my IPv6 address using [http://www.digwebinterface.com/] (http://www.digwebinterface.com/) getting 0.a.2.ip6.arpa., which seems fairly top level.

What to do? I think I could disable the AAAA record in the box, or persuade postfix not to use IPv6, but how?
Does MIAB need a switch to disable IPv6?

Have a nice day, Jarek


#2

Changed inet_protocols = all to ipv4 in /etc/postifx/main.cf.
MIAB complains about missing IPv6, but mails to freenet.de work. I will have to do it again on update.
Cheers, Jarek


#3

Disabling IPv6 in postfix is not the best solution, clients will still try to connect via IPv6. A better solution is to disable IPv6 of the box in the DNS, but this is a bit tricky, I had to dig around a bit.

  • edit /etc/mailinabox.conf, clearing the PUBLIC_IPV6 setting (# comments do not work here)
  • restart the box or the daemon (service mailinabox restart), so that the new environment gets loaded
  • force the update of the zone files by curl -s -d --force --user <user>:<pass> http://127.0.0.1:10222/dns/update (looked up in tools/dns_update. Await response “updated DNS:xyz” ). Or make a dummy change in the custom DNS via web interface.
  • wait for DNS propagation

Why so complicated? Is there an easier way if e.g. the IP would change?
Edit: Had to do it again after update.